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Abstract

Vibration control is very important in many areas including machine operation and 

daily life. Semi-active vibration control integrates a tuning control scheme with a tunable 

vibration absorber for suppression o f  vibration due to a harmonic excitation with a 

variable excitation frequency.

The electromagnetic vibration absorber (EMVA) is a semi-active vibration device 

whose stiffness can be tuned on-line. In this study, the EM VA is used for non-collocated 

vibration control. The study consists o f two parts. In the first part, the characterization o f  

the EMVA is revisited using a commercial FE package, Comsol Multiphysics. Various 

single physics models are built including the electromagnetic coil, the electromagnetic 

coil with a core, and a permanent magnet (PM) placed between a pair o f  PMs. These 

models are used to study the magnetic density in the gap o f the electromagnet. A 

coupling model that involves magnetism and structural mechanics is built. This model is 

used to study the factors that affect the magnetic stiffness.

In the second part, the EMVA is implemented to suppress vibration o f  a structure that 

can be modeled as a three-degree-of-freedom system. The non-collocated control theory 

is reviewed. The EMVA is modified to allow both manual adjustment and on-line tuning. 

Three different control methods, FFT-based method, FFT-based plus fine tuning method, 

and RMS-based method, are developed. The experimental results using the three methods 

are compared.
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Chapter 1 

Introduction

Vibration is periodic or non-periodic motion. Occasionally vibration is desirable, such 

as musical instruments or hydraulic hammers. But more often, vibration is undesirable. It 

wastes energy and creates unwanted sound. The vibrations o f  engines, instruments, 

buildings, or any mechanical devices in operation are usually unwanted. For example, 

electronic components used in airplanes, automobiles, machines, and so on may fail 

because o f  vibration, shock, and/or sustained vibration input. I f  the vibration does not 

affect the proper operation o f a machine, it can be neglected. But as the vibration 

becomes severe to damage the system, vibration suppression is necessary. In order to 

suppress the vibration, various methods are used. In the following section, these issues 

are identified through an overview of structural vibration control.

1.1 An Overview of Vibration Control

In general vibration suppression can be achieved by design, isolation, or control. In the 

design stage, all attempts are made to minimize the possibility o f inducing vibration. For 

example, if a system experiences resonance, changing the natural frequency o f  the system 

can fix the problem. If  vibration is caused by a centrifugal force due to an imbalance 

mass, eliminating the imbalance mass can solve the problem. But this is not an easy work. 

Practically before a system is made, knowing the natural frequency and the imbalance 

mass without testing is not possible.

The second way to deal with vibration is to isolate the source o f  vibration from the 

system o f interest or to isolate the system from the source o f vibration. This can be done 

by using highly damped materials as dampers to change the stiffness and damping 

between the source o f vibration and the device that is to be protected from the vibrations. 

Changing the damping o f a damper decreases the amplitude o f the vibration [1], but at the 

same time the achievable attenuation is reduced [2], The function o f the damper actually 

dissipates vibration energy over a range o f frequencies [3]-[4], By changing the damper

1
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to an optimal value, the damper is used to decrease the vibration. In [5], a bridge-friendly 

control strategy is developed to reduce the vibration o f a bridge through changing the 

damping value o f the vehicle. In [6], electro-rheological (ER) and magneto-rheological 

(MR) materials are also used as variable dampers.

The methods o f vibration control can be classified as passive, active, and hybrid. The 

passive control involves the use o f reactive or resistive devices that either load the 

transmission path o f the disturbing vibration or absorb vibratory energy. Invented in 1909 

by Den Hartog, vibration absorbers are a passive vibration control device which has been 

widely used in machinery, aviation, construction, structures [6]-[8] and sound radiation 

reduction [9], For example, vibration absorbers with viscous damping have been used on 

Taipei Financial Center [10], and the London Millennium Footbridge [11]. Active control 

also loads the transmission path but achieves this loading through the use o f actuators that 

generally require external energy, such as piezoelectric actuators to reduce the vibration 

o f  a thin circular aluminum plate [12]. Hybrid control integrates a passive approach with 

an active control approach. The hybrid control is intended to reduce the amount o f  

external power necessary to achieve control. The hybrid approach is also referred to as 

adaptive-passive control, or semi-active control. The semi-active control systems are 

widely used in the field o f vibration control, since they combine the advantages o f both 

passive and active control systems. On one hand, they keep the reliability o f  the passive 

systems even in the event o f power loss; on the other hand, they maintain the versatility 

and adaptability o f active systems without a great amount o f power consumption.

Generally, the mechanical properties o f the semi-active systems, such as the stiffness 

and/or the damping value, can be tuned based on the feedback from the measured 

response and /or the excitation. Firstly, damping value adjusting methods are described. 

In [13], by increasing the voltage source on the piezoelectric material, the damping value 

o f a beam is enhanced to control the vibration o f the beam. In [14]-[15], a variable 

stiffness absorber was developed by varying the length o f a cantilever beam. In [16], a 

semi-active hydropneumatic spring and damper system with variable damping coefficient 

and stiffness was designed. The stiffness is varied by changing gas volumes and the 

damping value is varied by controlling the fluid passing through a valve (semi-active 

damper). A resetting semi-active stiffness damper was developed by releasing the

2
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vibration energy in appropriate time instant through switching a valve open and close in 

this damping system [17]. In [18], by changing the electric field to ER, the damping value 

was changed such that ER dampers were used for truss vibration suppression. In [19]- 

[20], typical MR dampers were studied. Damping value is controlled by electromagnet. 

In [21]-[22], semi-active friction dampers were studied. Secondly, stiffness adjusting is 

reviewed. In [22], a plane rhombus spring assembly with a single absorber mass was 

developed. The stiffness o f the spring assembly is adjusted as the shape o f the rhombus is 

changed by applying an electromechanical actuator. In [23]-[24], the stiffness o f the 

absorber is adjusted by changing the number o f active spring coils used to perform 

control. This same absorber was used in collocated and non-collocated control, 

respectively. In [25]-[26], an electromagnetic vibration absorber (EMVA) was developed 

for vibration suppression.

1.2 Review of the Previous Study on Non-collocated Control and the 
EMVA

In many applications o f vibration control, the sensor (at the point o f  interest for control) 

is collocated with the vibration control actuator. It is called the collocated control. For 

some applications it is not possible to collocate the vibration control actuator at the 

location o f interest, and the control becomes non-collocated. Non-collocated control is 

more complicated than collocated control [20]. Most previous researches on the non- 

collocated vibration were active control. In [27], an H m controlled was used to reduce

the effects o f solar array vibrations on telescope pointing jitter for the Hubble Space 

Telescope. In [28], a controller designed with the structured singular value approach was 

applied for a large space structure which has closely spaced, lightly damped modes. In 

[29], a time delay in the feedback loop to compensate for the phase difference between 

the actuator and sensor was introduced. This time delay reduces the non-collocated 

vibration control problem to the collocated case. In [30], a neural network based on 

forward dynamics and decentralized control was used to attenuate vibrations. In [31], an 

H m controller was developed to manipulate an active actuator in suppressing the

3
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vibration o f a truss structure. In [24], adaptive-passive approach for solving the non- 

collocated vibration control problem was studied.

In [25]-[26], an EMVA, which has advantages o f rapid reaction and motionless 

adjustment, was applied on a one degree o f freedom (1-DOF) system. It is a collocated 

control. By varying the current to the electromagnet, the absorber stiffness can be on-line 

adjusted such that it can suppress a system excited by a harmonic force with a variable 

frequency.

1.3 Objectives of the Thesis Research

The main objective o f  the thesis is to apply the EMVA to the non-collocated control. 

The study aims to:

1. modify the EMVA such that it is suitable for the non-collocated control;

2. characterize the EMVA using a Comsol Multiphysics simulation;

3. develop and test the control strategies.

1.4 Outline of the Thesis

Chapter 2 characterizes the EMVA through an analytic computation and Comsol 

Multiphysics simulation. The chapter describes the results obtained by the analytic 

computation method and compares them with those from Comsol M ultiphysics 

simulation. Chapter 3 presents the theory o f the non-collocated control. In this chapter, 

the model is analyzed and tuning law is established. Chapter 4 applies the modified 

EMVA to the non-collocated control o f vibration o f a 3-DOF structure. Three control 

methods are tested. Chapter 5 presents the conclusions and suggests the future work.
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Chapter 2 

Tunable Electromagnetic Vibration Absorber (EMVA)

In order to apply the EMVA in vibration control, it is necessary to understand its 

characteristics. In this chapter, a commercial package Comsol Multiphysics is used to 

characterize the EMVA. The intention is to compare the results from Comsol with those 

from the approximate analytical method developed in [25].

2.1 The Original Design of the EMVA

Tunable electromagnetic vibration absorber (EMVA) is a semi-active vibration 

absorber. A CAD drawing o f the EMVA developed in [25] is shown in Figure 2.1. It 

consists o f  a clamped-clamped beam, a permanent magnet (PM) that is embedded in the 

middle o f the beam, and an electromagnet. The PM-beam assembly is placed between the 

poles o f the electromagnet. The PM plays a dual role: acting as an absorber mass and 

forming a variable spring by interacting with the electromagnet through varying the direct 

current (DC) o f the electromagnet.
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■Beam

-Permanent Magnet

-Electromagnet

Figure 2.1 The EMVA

2.2 The Modified EMVA

As shown in Chapter 3, non-collocated control demands the EMVA to have a large 

adjustment. To meet this requirement, the EMVA was modified. Figure 2.2 shows the 

modified EMVA. The major change was made to the way o f supporting the absorber 

beam by adding two movable beam holders and two tensioners. Through changing the 

positions o f  the beam holders the beam length can be varied. By adjusting the tensioners, 

the beam tension can be varied. Both ways alter the absorber stiffness. Table 2.1 shows 

the parameters o f the EMVA. It should be noted that a majority o f these parameters have 

the same values as in [25]-[26] exception o f ma , 8  and h .

6
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Figure 2.2 The modified EMVA

Table 2.1 EMVA system parameters

Symbol Description Quantity, Unit

ma Absorber mass 0.2515 kg

Inner radius o f the electromagnetic coils 11.0 mm

R2 External radius o f the electromagnetic coils 20.0 mm

L Circumference o f the electromagnet 314.16 mm

N Number o f the coils 784

5 The gap between two pole faces o f the electromagnet 43.0 mm

I Length o f  PM 48.0 mm

w Width o f  PM 22.0 mm

h Thickness o f PM 38.0 mm

Mo Permeability o f free space 4 ;rx l0 “7 H/m
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2.3 Characterization of the EMVA

As shown in Figure 2.3, the stiffness o f the EMVA is composed o f three parts: 

constant spring created by the absorber beam, constant spring kc2 formed by the 

interaction between the PM and the core o f the electromagnet, and variable spring kv 

generated by the interaction between the PM and the electromagnet. The value kcl is 

adjusted by the tension and length o f the beam; the value kc2 is determined by the gap 

between the PM and the core o f the electromagnet, and the value kv varies with the 

current o f the electromagnet.

W \A Av w v

Figure 2.3 Stiffness o f the EMVA 

The total stiffness ka of the absorber is the sum o f these three parts

* « = * c l + * c 2 + * v  ( L 1 )

When the absorber mass ma has a small displacement from its equilibrium position, the 

restoring force applied on mass ma by the beam is proportional to this displacement. The 

larger the displacement is, the larger the force dragging the absorber mass ma back to the 

equilibrium position. Therefore kv] is considered linear over the range o f  the beam ’s 

displacement. As the displacement occurs, one pole o f the PM is closer to one pole o f the

8
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electromagnet, the force attracting the PM away from the equilibrium position increases. 

As the result, kc2 is negative. The variable stiffness kv varies from negative to positive as

the current changes over its full range. To make sure that ka is positive, it must be met 

that kcX >| kc21 + 1 krmm | . If this condition does not hold, the function o f the absorber will 

be lost.

In [25]-[26], an approximate analytical method was used to characterize the EMVA. In 

the present study, the commercial package, Comsol Multiphysics, is used to conduct the 

characterization analysis. The results are compared with those from [25]-[26]. Comsol 

M ultiphysics is a software package based on the finite element methods for the 

simulation o f any physical process described by partial differential equations. It features 

the state-of-the-art solvers that can deal with complex problems, while its intuitive user 

interface is designed to provide ease o f use and flexibility.

2.4 The Approximate Analytical Method

This section presents the results obtained by using the approximate analytical method 

developed in [25] and [26]. Owing to the fact that a majority o f parameters have the same 

values as in [25]-[26], the certain results (see Figures 2.6, 2.7 and 2.9) remain the same as 

in [25]-[26]. The force acting on the PM caused by the electromagnet depends on the 

magnetic flux density o f the electromagnet, the magnetic flux density o f the PM, and the 

permeability o f the electromagnetic core. To determine the magnetic stiffness between 

the electromagnet and the PM, the magnetic flux density o f the electromagnet needs to be 

first evaluated. Due to the complicated shape o f the EMVA, the following strategy was 

employed. The electromagnet, composed o f coils which are wound around the C-shaped 

core, see Figure 2.2, is o f a torus shape. Simplification is made by cutting the torus into 

two halves, straightening each o f  them to a hollow cylinder with an inner radius Rx and 

an outer radius R2. and a length L I 2 ,  where A,, R2, and L are the inner radius, the

outer radius o f  the torus, and the perimeter o f the center line o f  the torus, respectively, as 

shown in Figure 2.4.

9
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Figure 2.4 Simplified electromagnetic coils and core

2.4.1 Interaction between the Electromagnet and the PM

The flux density o f such a hollow cylinder can be found by examining first the 

magnetic field from a circular current loop with a radius a , shown in Figure 2.5. 

Expanding on the Bio-Salvart law, which determines the magnetic field contribution o f a 

current carrying element, the flux density Bk in the radial direction r and the flux 

density Bk in the axial direction 2  can be expressed as [32].

r

Figure 2.5 Circular current loop [26]

10
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where E\ and Ei  are the complete elliptic integrals o f the first and second kind, 

respectively. They are o f  the forms:

- 1- 1 / 2

Aar
— sin2 6 dd (1.4)

[(a + r)2 + z 2]

(1.5)

Using Equations (1.2) and (1.3) the magnetic flux density from a single current loop 

can be found. The total magnetic flux density o f half o f the whole torus can then be 

obtained by superposing contributions o f individual coils. By integrating Equations (1.2) 

and (1.3) in both the radial and axial directions, the total contribution o f  the magnetic flux 

densities o f the cylinder is found:

where Bsr and Bsz are the radial and axial magnetic flux density from one o f  the current 

carrying cylinders, respectively, with the origin located at the center o f the end face. Note 

that in the equations above, the loop current should be substituted by

f/i2 rI, /2
Bsr -  Bi,(a,r,z + X)d.zda

CRl t U 2
z + X )dzda

(2 .6)

(2.7)

N I
(2 .8)i -

{ R \ -R i ) L

1 1
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where I  is the coil current, and N  is the number o f the coils. The total magnetic flux 

densities B,- and B= from the two poles o f  the current carrying coils are found by 

summing the densities from the right and the left cylinders. Figure 2.6 illustrates the axial 

magnetic flux density along the centerline o f  air gap, from the two poles o f  the 

electromagnet respectively when the current is /  = —1.0 A. The total f lu x  density B, is 

obtained by adding these two components point to point.

x 1Cf3
Cl

<— ■ - 0.6

1.2

1.8
- 0.02 - 0.01 0 0.01 0.02

Axial displacement (m)

Figure 2.6 Axial magnetic flux density from the electromagnet, along the centerline o f 

the gap: dash-dot, magnetic flux density from the right cylindrical coils; dot line, 

magnetic flux density from the left cylindrical coils; solid line, total magnetic flux density 

[26]

When the core is taken into consideration, the magnetic field between the gap space o f  

two pole faces o f the electromagnet is enhanced greatly. The effect is included by 

introducing an amplification number /j.r , which is the relative permeability o f  the steel 

core. Further, for a certain coil, the flux available in the air gap is solely affected by the

12
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term /j.r!y where the denominator y  is called the leakage factor, defined as the ratio o f 

the total flux to the gap flux. Due to many factors, such as structure, materials, the term 

j i r l y  is often determined by experiment. In [25]-[26], a DC magnetometer (AlphaLab, 

Model: DCM) was used to measure the axial magnetic flux density at the points along the 

centerline o f the gap o f  the electromagnet as it was loaded with four different amplitudes 

o f DC current. The value /j,r!y was determined in the following way: a modified 

computed axial flux density was found by multiplying a trial value fXrly  to the 

computed Bc, ; then the squared error between the measured axial flux density and the 

modified computed axial flux density was found; by varying the values o f j u J y  the 

squared error was minimized. It was found that the value o f n>- / y  = 27.5 results in the 

least discrepancy, more specifically, accuracy is at 94% within the displacement o f 

[-0.015, 0.015], where the origin is located at the center o f  the air gap. Figure 2.7 shows 

the magnetic flux density o f  the electromagnet with the core.

- 0.01

- 0.02 ♦ y

£  -0.03 
mN
f  -0-04

/♦
-0.05

CO
-0.06 -

-0.07

-0.08

-0 09 1-------- 1---------1--------- '-------- 1—
-0.025 -0.02 -0.015 -0.01 -0.005 0.005 

Displacement (m)

Figure 2.7 Magnetic flux density from the electromagnet, along the centerline o f the gap, 

(a) I  = -  0.5 A, (b) I  = -  1.0 A, (c) I  = -  1.5 A, (d) I  = -  2.0 A. Dot line, experimental; 

solid line, calculated [26],
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Figure 2.8 The radial magnetic flux density o f the electromagnet when I  = -  1.5 A.

Using the above described method, the radial and axial components o f the magnetic 

field in the pole gap can be found. Figures 2.8 and 2.9 show the values when the 

electromagnet carries a current o f  7 = -1 .5  A. From Figure 2.8, it can be seen that the 

peaks o f  the radial flux density B,- occur on the pole faces at a distance o f 15 mm from 

the centerline o f the axis o f the cylinders, i.e., the mean radius o f the coils; and it 

diminishes to zero along the centerline o f  the coils. By contrast, in terms o f absolute 

value, the axial flux density B= peaks along the centerline o f the coils, reaching 

maximum on the pole faces and minimum in the middle o f the air gap.

14
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Figure 2.9 The axial magnetic flux density o f the electromagnet when 1=  -  1.5 A.

With the flux density o f the electromagnet available, the interaction force between the 

electromagnet and the PM is given by

F: = - d W  /  dz (2.9)

where W  is the energy o f interaction o f the electromagnet and the PM. The energy W  

may be calculated as the integral o f  the pole density on pole surfaces S', and S 2 (refer to

Figure 2.3) o f the PM times the potential from the electromagnet. If  <£>("' is the potential

from the electromagnet at the pole face S’, and (p™ that at the pole face S2, then

W  = J Mq>™dS +h > J ( -M )c p ^ d S (2 . 10)

or
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where Bv = ~/iQ , i= l,2 , is the electromagnetic flux density on the pole faces 5,
8z

and S2 o f  the PM, respectively. M  is the magnetization o f  the PM. Equation (2.11) 

indicates that the force F: is proportional to the difference between the total flux over the 

pole faces S { and S 2. It should be noted that, due to the symmetry o f distributions o f  the 

radial flux, no net interaction force exists in the radial direction. Figure 2.10 shows the 

plots o f the electromagnetic force F, versus the displacement o f  the PM for four different 

amplitudes o f the coil currents. The slopes o f force-displacement curves present the 

electromagnetic stiffness kv .

4 

3 

2 

1

0  
z

-1 

-2  

- 3  

- 4
- 2  -1 .5  -1 -0 .5  0 0.5 1 1.5 2

Displacement (m) x 10 3

Figure 2.10 Force and the displacement o f the PM with the origin at the gap center: (a) 

/  = -  2.0 A, (b )7 = -  7.5 A, (c) I  = -  7.0 A, (d) I  = -  0.5 A.
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2.4.2 Interaction between the Core and the PM

The interaction between the PM and the core forms kc2. The orthorhombic PM can be 

represented by two rectangles o f surface pole density a  -  ± M , where M  is the magnet 

strength or magnetization o f  the PM. Figure 2.11 shows an orthorhombic PM. The 

magnetic flux density on the central axis at a distance z  from the PM can be calculated 

as [26]

Figure 2.12 shows the magnetic flux density along the Z-axis, obtained by using 

Equation (2.12) with M  = 3 95 .8x l03 A/m [25]-[26].

- s in  1 (2 . 12)

T

Figure 2.11 A PM block
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Figure 2.12 Magnetic flux density along the centerline o f the PM with the origin located 
at the center o f  the pole face.

The force between the PM and the core o f the electromagnet is expressed as 

F  = ccB 2sA  (2.13)

where a  is a constant to be determined, A  is the area o f  the PM surface, and Bs is the

flux density produced by the PM at the surface o f the coil. Let Fi be the interaction force

between the right end o f the core and the PM and F2 that between the left end o f  the core

and the PM (see Figure 2.3). When the PM is located in the exact middle o f  the air gap o f 

the core, Fx -  - F 2 such that the net force is zero. When the PM is moved to right,

\F[ > |F2 j , and vice versa. Using Equation (2.13) the net force acting on the PM  is given 

by

18
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F  = Fx- F 2 = a A { B l - B 2n ) (2.14)

where 5 sl and Bx2 are the flux densities at the right and left end o f  the core, respectively. 

Figure 2.13 shows the plot o f the interaction force F  as a function o f  displacement o f the 

PM. Therefore, stiffness kc2 can be approximated as a constant value o f -1236 N/m.

D
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■2

■3

■4

-5 L-  
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Displacement (m) ■ ^g-3

Figure 2.13 Force between the PM and the core.

2.5 Comsol Multiphysics Simulation

To model the EMVA accurately using an analytical method is an extremely 

complicated task. On the other hand, Comsol Multiphysics offers a possibility o f  solving 

the problem numerically. In this study, both the single physics and multiphysics 

functionalities o f Comsol are explored for the purpose o f the EMVA characterization.
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2.5.1 Simulation of the Electromagnetic Coil

First the electromagnetic coil without a core is simulated. Attempt was made to model 

the coil using a series o f  the current loops. However, such a model demands a large 

memory and computational time. Thus the coil was simplified as a thin-shell hollow torus. 

Figure 2.14 shows a Comsol model for the electromagnetic coil. The model is built in 

AC/DC Module> Statics > Magnetostatics mode. The model meshing information is as 

follows. Number o f degrees o f freedom is 58131. Number o f mesh points is 1356. 

Number o f  elements is 7395. Number o f boundary elements is 1946. The torus carries a 

constant current flowing through it along the direction as shown in Figure 2.15. The 

parameters o f the hollow torus are given in Table 2.2. It is noted that all the parameters 

are the same as those given in Table 2.1 except r, and r2. As the thin-shell hollow torus

is used to simulate the electromagnetic coils, its inner and external radiuses are selected 

between the range o f  those o f  the electromagnetic coils.

Table 2.2 Electromagnetic coil parameters in Comsol

Symbol Description Quantity, Unit

n Inner radius o f the electromagnetic coils 12.0 mm

ri External radius o f the electromagnetic coils 15.0 mm

R Radius o f the torus center line 50.0 mm

Jo External current density Equation (2.15), A / m 2

N Number o f the coils 784

r Medium radius o f the electromagnetic coil 0 i + r 2) /2

S Arc length o f the opening o f the torus 0.04445 mm

I Current in the coil 0 .5 ,1 .0 ,1 .5 ,2 .0 ( A )

A current flows in the circular direction on the transverse cross section o f  the hollow 

tube. In the Comsol model, the current density needs to be specified. The current density 

that flows in the cross section o f the torus is obtained by

20
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where I N  is the total current and (2n R - S ) { r 2- r x) is the area in which the current 

flow s through. In Comsol Multiphysics, the x  , y  and z components o f  the current 

density need to be defined. They are given as the follows:

r  _ _  JpXy J  _ j 0( 4 x 2 + z 2 - R) _  J 0z y __
■v n r y  r ’ - n  fr y x  + z  1 r \ jx '+ z ~

The resultant o f the three values represents the current density.

Figure 2.14 Comsol model for the electromagnet coil

Figure 2.15 shows an arrow plot o f the current density o f the electromagnetic coil. 

Figure 2.16 shows an arrow plot o f  the magnetic flux density. It is noted that the 

directions o f  the magnetic flux densities on surfaces A and B are not parallel to one
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another. If the current density J 0 determined using Equation (2.15) is used in the

simulation, the magnitudes o f the magnetic densities are quite different from those 

obtained using the approximate analytical method. In order to make the results from the 

Comsol model and those from the analytical model comparable, J 0 is multiplied by an 

adjusting factor o f 1.76 which was determined such that the magnetic density at the 

center o f  the opening from the Comsol model is as close as possible to that from the 

approximate analytical model. Figure 2.17 shows the magnetic flux densities in the re­

direction on the center plane when the currents are o f four different values I  = -0 .5  A , 

7 = -1 .0  A , 7 = --1.5 A , and 7 ==-2.0 A , respectively. Multiplying Equation (2.15) by 

a factor o f  1.76, the corresponding current densities are found to be 

J 0 = 1923.16x103 A /n r , 2046.33xlO3 A/m2 , 3069.49xlO3 A/m2 , and

4092.65xl03 A/m2, respectively. Under the condition o f J 0 = 2046 .33x l03 A/m 2, the 

magnetic flux density at the middle position is close to that o f the analytic result as 

7 = -1 .0  A . The magnetic flux density reaches the maximum at the position o f two faces 

A and B, and the minimum at the middle position along the x-axis. The magnetic flux 

density corresponding to 7 = -1 .0  A is similar to that shown in Figure 2.6. It is noted

that the magnetic flux density changes abruptly at two locations. The problem is possibly 

produced by using a single thin-shell torus to approximate the actual electromagnetic coil.
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Figure 2.15 Arrow plot o f the current density in the electromagnet coil.
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Figure 2.16 Arrow plot o f  the magnetic flux density o f the coil
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Figure 2.17 The axial magnetic flux density from the electromagnet along the centerline 

o f the gap. (a) I  = - 0 .5  A; (b) I  = - 1 .0  A; (c) / =  - 1 .5  A; (d) /  = - 2 .0  A.
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2.5.2 Simulation of the Coil with a Core

Figure 2.18 shows the model o f the electromagnetic coil with a core in Comsol 

M ultiphysics simulation. The model is built using AC/DC Module> Statics > 

M agnetostatics mode. Physical conditions o f the hollow torus are the same as in Section 

2.5.1. According to [33], the relative permeability o f the core (iron) changes in a wide 

range, from 25 to 200 x 103. If  the value o f  the relative permeability o f the core increases, 

the magnetic flux density will also increase. It is found that when the relative 

permeability is 25 and current density J 0 is multiplied by a factor o f 3.5, the magnetic 

flux density curves are closest to those obtained in the analytic calculation given in 

Figure 2.7. As it was mentioned in Section 2.5.1, the model has only one torus which 

does not simulate the electromagnetic coils exactly. Thus some parameters have to be 

adjusted according to the analytic results.

/  ®

Figure 2 .18 Model o f the electromagnetic coil with the core.

Figure 2.19 shows an arrow plot o f the coil with a core. The magnetic arrows radiate 

from surface A and converge on surface B. It is noted that with the core, the arrows o f the 

magnetic density between the gap o f the C-shape coil become nearly parallel to each 

other. Figure 2.20 shows the magnetic flux density along the x-ax is in the centerline.
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The magnetic flux density is increased greatly due to the effect o f  the core. The two 

abrupt change points in Figure 2.17 disappear. It may be due to the function o f the core 

which “guides” the magnetic flux density in the circular direction o f the coil.

B

Figure 2.19 Arrow plot o f the magnetic flux density o f  the coil with the core.
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Figure 2.20 The axial magnetic flux density o f the electromagnet with the core. The 

origin is at the gap center, (a) I  = -0 .5  A; (b) I  = - 1 .0  A; (c) I  = -1 .5  A; (d) I  = -2 .0  A .

2.5.3 Simulation of the PM

The PM model built in Comsol Multiphysics is shown in Figure 2.21. The model is 

built using AC/DC Module>Statics>Magnetostatics mode, no current. The magnetization 

o f th e P M is  395.8xlO3A/m.
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Figure 2.21 PM model

Figure 2.22 shows an arrow plot o f the magnetic flux density field. Figure 2.23 shows 

the magnetic flux density o f the PM, starting from the point “O” along the centerline (x- 

axis in Figure 2.21). The result is similar to that obtained by the analytic calculation (see 

Figure 2.12). The magnetic flux density decreases as the distance to the surface increases.

A rrow : M agnetic  flux d e n s ity  [T ]

Figure 2.22 Arrow plot o f  the magnetic flux density o f the PM
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Figure 2.23 Magnetic flux density along the centerline o f the PM with the origin located 

at the center o f the pole face.

2.5.4 Determination of the Interacting Force between the Core and the 
PM

Figure 2.24 shows the model with the PM in the gap o f the core. To find the net force 

acting on the PM, the PM is placed in different locations along the centerline. Table 2.3 

lists the PM positions and their corresponding magnetic forces. In the table Akl is

calculated by

M , = i = 2 , 3 , -  (2.16)
T - 'V i

29

Reproduced with permission of the copyright owner. Further reproduction prohibited without permission.



where Fi is the force corresponding to the position x.t and F,_{ is the force corresponding

to the position . The average stiffness is -1 4 .6 x l0 3 N/in . Figure 2.25 plots the

simulation result together with a linear regression result. It is found that as the PM is in 

the middle o f the gap, the force is small, and as the PM becomes closer to the core, the 

attracting force increases. Comparing with the result in Figure 2.13, the stiffness obtained 

by the present model is much greater than that obtained by the analytic calculation. This 

is expected because the distance between the PM and the core o f  the present setup is 

much smaller than that in [25], Because it is a 3-D model which consumes much memory, 

it is impossible to select a finer mesh in the solution process.

Figure 2.24 The PM placed in the gap o f  the core.

30

Reproduced with permission of the copyright owner. Further reproduction prohibited without permission.



Table 2.3 Force and position

Position (m) Force (N) Mi (N/m) Position (m) Force (N) Mk (N/m)
0.0000 0.4636 0.0000 0.4636
0.0001 -1.7494 -12858 -0.0001 1.1587 -6951
0.0002 -1.9555 -2061 -0.0002 1.6165 -4578.5
0.0003 -3.8795 -19240 -0.0003 3.6867 -20702
0.0004 -6.0146 -21351 -0.0004 3.9812 -23647
0.0005 -5.9081 1065 -0.0005 5.8064 -18252
0.0006 -8.3227 -24146 -0.0006 6.8445 -10381
0.0007 -8.0918 2309 -0.0007 8.1986 -13541
0.0008 -9.7281 -16363 -0.0008 10.4380 -22394
0.0009 -10.8716 -11435 -0.0009 7.9760 24620
0.0010 -12.3860 -15144 -0.0010 12.0533 -44773
0.0011 -12.3869 -9 -0.0011 11.0886 9647
0.0012 -14.4446 -109423 -0.0012 14.9852 -38966
0.0013 -15.6732 -12286 -0.0013 15.6643 -6791
0.0014 -16.0735 -4003 -0.0014 16.1305 -4662
0.0015 -18.02.13 -19478 -0.0015 18.4883 -23578
0.0018 -20.1370 -7052.3 -0.0018 20.8633 -7916.7
0.0020 -23.3599 -8057.3 -0.0020 24.6281 -9412
0.0022 -25.8830 -12615.5 -0.0022 26.8637 -11178

 Simulation result
 Linear regression

o
Ll_

-10

-20

-0.5 2.5
,-3

0.5
Dsiplacement (rn) x 10

Figure 2.25 Force acting on the PM vs. its position
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2.5.5 Determination of the Interacting Force Using a Simplified Model

When the PM is placed in the gap o f the coil with a core shown in Figure 2.19, the 

electromagnetic force corresponding to the current can be found. Unfortunately, due to 

the limited memory o f  the computer, this kind o f  model cannot be run. Therefore a 

simplified model is used. The torus-like electromagnet is replaced by a pair o f magnetic 

cylinders as shown in Figure 2.26. The magnetizations o f the cylinders are chosen such 

that the magnetic flux density curves formed by the two magnetic cylinders are close to 

those in Figure 2.20, as shown in Figure 2.27. The magnetization values o f each cylinder 

are adjusted to 4 5 x l0 3 , 9 5 x l0 3 , 1 40x l03 , and 185 x 103 A /m . The PM with a 

magnetization o f 395.8x 103 A/m is placed between these two cylinders and a simplified 

model is formed. Figure 2.28 shows this simplified model. By placing the PM on 

different positions between the gap o f this pair o f the PMs, the force applied on the PM 

varies. Table 2.4 shows the relationship between the magnetic force and the PM position 

in four different magnetizations. Figure 2.29 plots this relationship. The stiffness is 

around -1240  N/m when the current is I  = -2 .0  A . This means the adjustable range o f

the stiffness kv is between -1240 and 1240 N/m when the current is varied from 

/  = -2 .0  A to 7 = 2.0 A .

mpie(4)= 1.SS4S An ow: Msgrvitos flu* donoity (T]

?U

Figure 2.26 A pair o f  magnetic cylinders
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Figure 2.27 Magnetic flux density o f the simplified model. The origin is at the gap center, 

(a) 4 5 x l0 3 A/m ( /  = -  0.5 A); (b) 9 5 x l0 3 A/m ( /  = -  1.0 A); (c) 140xl03 A/m 

( / = -  1.5 A); (d) 185xl03 A/m (I = -  2.0 A).

m p r e ( 4 ) =  1 .S 5e5  A rrow : M a g n etic  flux d e n s ity  [T ]

Figure 2.28 The simplified model with the PM
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Table 2.4. Magnetic force and displacement

Magnetization (A/m)

Displacement (m) 45000 95000 140000 185000

0.0001 -0.0083 -0.0371 -0.0805 -0.1406
0.0002 -0.0183 -0.0814 -0.1768 -0.3086
0.0003 -0.0181 -0.0809 -0.1756 -0.3066
0.0004 -0.0274 -0.1221 -0.2652 -0.4631
0.0005 -0.0310 -0.1383 -0.3003 -0.5244
0.0006 -0.0386 -0.1718 -0.3731 -0.6515
0.0007 -0.0413 -0.1841 -0.3998 -0.6982
0.0008 -0.0584 -0.2601 -0.5649 -0.9865
0.0009 -0.0575 -0.2563 -0.5566 -0.9719
0.0010 -0.0723 -0.3222 -0.6997 -1.2218
0.0011 -0.0775 -0.3454 -0.7502 -1.3099
0.0012 -0.0872 -0.3886 -0.8439 -1.4737
0.0013 -0.0971 -0.4329 -0.9401 -1.6416
0.0014 -0.1061 -0.4730 -1.0272 -1.7937
0.0015 -0.1145 -0.5103 -1.1083 -1.9353
0.0016 -0.1188 -0.5294 -1.1497 -2.0076
0.0017 -0.1342 -0.5979 ! -1.2985 -2.2674
0.0018 -0.1401 -0.6243 -1.3558 -2.3674
0.0019 I -0.1510 -0.6732 -1.4619 -2.5527
0.0020 1 -0.1461 -0.6511 -1.4140 -2.4691
0.0025 -0.1684 -0.7505 -1.6298 -2.8459
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Figure 2.29 Force acting on the PM vs. its position: (a) /  = -2 .0  A; (b) I  = -7 .5  A; 

(c) I  = -7 .0  A; (d) 7 = - 0 .5  A.

2.5.6 Simulation of the Interaction of the PM, the Electromagnet, and 
the Beam

The previous simulations do not include the effect o f  the absorber beams. With the 

multiphysics functionality o f Comsol, it is possible to build a model that couples the 

structural mechanics o f  the beam with the electromagnetic physics o f  the coil and the PM. 

To reduce the computational burden, a 2-D model is used. The model deals with magnets, 

force and structural deformation such that multiphysics modes are used. The model 

addresses a 2-way coupling between the deformations and the magnetic field. Figure 2.30 

shows the model built. The electromagnet is replaced by a pair o f  PMs referred to as 

upper PM (R10) and lower PM (R15), which are fixed in space. A PM (R2) referred to as 

the middle PM is placed in the middle o f the upper and lower PMs. Two beams (R l, R3) 

are attached to the left and right sides o f the middle PM, respectively. The other end o f  

each o f the beams is fixed. The beam-middle-PM assembly will be deformed when it is
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subjected to a force. The beams are made o f aluminium with Young’s modulus o f  7 x 10'° 

P a. The beam length is 0.1 m. Two different beam thicknesses, 0.0015 m (thick beam)

and 0.001 m (thin beam), are considered. The size o f the middle PM is

0.048x0.038 (m) (w id thx height) . The size of the upper and lower PMs is

0.048x0.04 (m) (widthxheight) . The magnetization o f  the middle PM is

395 .8x l03 A /m . According to the polarity o f  the upper and lower PMs, two cases are

studied. Figure 2.30 shows Case One in which the polarity o f  the upper and lower PMs is 

opposite to that o f  the middle PM, which corresponds to a positive current case in the 

electromagnet. In Case Two the polarity o f the upper and lower PM s is reversed, which 

corresponds to a negative current case in the electromagnet.

o.as:
; Rio

Beam R12 B eam
.RS

RJ.5
-0,05

PT1

-0 ,3 •0 ,2 0 0,1 0-15 Q.30.2

Figure 2.30 The 2-D coupling model.

The coupling model is built using three application modes: 1. the Perpendicular 

Induction Currents mode, Vector Potential in Quasi-Statics M agnetic from AC/DC
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Module, 2. the Plane Strain mode from the Structural Mechanics Module, and 3. the 

Moving Mesh (ALE) mode from Multiphysics Module. First, the Perpendicular induction 

current application mode computes the magnetic force acting on the middle PM. Then the 

Plane strain application mode computes the deformation o f the beams under the magnetic 

force and any external force applied. An iteration solution procedure must be used 

because the beam deformation will change the position o f the middle PM  so that the 

interacting magnetic force alters. The Moving Mesh (ALE-Arbitrary Lagrangian-Eulerian) 

application mode deals with the deformed mesh.

In the coupling model, the magnetizations o f  the upper and lower PMs are adjusted to 

the equivalent values in Section 2.5.5. The magnetic flux densities between the upper and 

the lower PMs without the middle PM can be found by setting the relative permeability 

o f the middle PM to be that o f the air. Figure 2.31 shows the magnetic flux densities 

along the center line o f the lower and upper PMs. Note that the positive magnetization o f 

the upper and lower PMs corresponds to Case Two mentioned previously. Figure 2.32 

shows an arrow plot o f the magnetic flux density when M = -185  x 103 A/m and the thick 

beams are used.
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Figure 2.31 Magnetic flux density o f the coupling model: (a) 45 x 103 A/m ( /  = -  0.5 A); 

(b) 95* 103 A/m ( /  = -  1.0 A); (c) I4 0 x l0 3 A/m (I = -  1.5 A); (d) 185xl03 A/m 

( /=  -  2.0 A).

TftfT)Tf

Figure 2.32 Arrow plot o f the magnetic density for Case One.

To find the stiffness o f this setup, an external force is applied in the center (PT1) o f  the 

middle PM in the ^-direction. Then a simulation is conducted and the displacement o f  the 

middle PM is found. The relationship between the applied forces and the displacements
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o f the middle PM can be found. Figure 2.33 compares the results o f  both Case One and

Case T w o for the thick beam  case. Figure 2 .34  com pares the results o f  both Case One and

Case Two for the thin beam case. Figure 2.35 shows a k  corresponding to the 

displacement o f  the thick beam, where a k  is obtained by equation (2.16). From the 

figures, the following observations can be drawn. First, the relationship between the 

applied force and the displacement is not linear. Second, such a nonlinear relationship 

indicates that the setup possesses the characteristics o f  a harden spring, i.e., the stiffness 

increases with the increase o f  the spring deformation. Third, the increase o f the 

magnetizations o f the upper and lower PMs results in a decrease o f  the displacement o f  

the middle PM, i.e., an increase o f the magnetic stiffness. Fourth, a decrease o f the 

magnetization magnitude will soften the magnetic spring. Fifth, Case Two softens the 

overall stiffness. Sixth, in Case One the stiffness a k  increases with an increase o f the 

magnetization magnitude while in Case Two, the stiffness a k  decreases with an increase 

o f the magnetization magnitude.

LL

-20

-3 0

-4 0

-5 0
2 -1 .5 1 0 0.5 1 1.5 2-0 .5

Dsiplacement (m) x 1 0  3

Figure 2.33 Force vs. displacement (thick beam): (a) -1 8 5 x l0 3 A/m; (b) -4 5 * 1 0 3 A/m; (c) 

4 5 x l0 3 A/m; (d) 185xl03 A/m.
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Figure 2.34 Force vs. displacement (thin beam): (a) — 185x 103 A/m; (b) - 4 5 x l0 3 A/m; (c) 

4 5 x l0 3 A/m; (d) 185x103 A/m.
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Figure 2.35 a k  vs. displacement: (a) -1 8 5 x l0 3 A/m; (b) -4 5 x l0 3 A/m; (c) 45><103 A/m; 

(d) 185x]03 A/m.

2.6 Comparison of the Two Techniques

The original intension o f  this study was to explore the possibility o f using a 

commercial finite element package to characterize the EMVA. The experience has shown 

that building an accurate model for the EMVA using Comosl is challenging due to 

several factors such as a lack o f a proper training in the use o f  Comsol and a memory 

limitation, etc. Nevertheless, the study has resulted in some useful experience and 

revealed a great potential in using Comsol to solve similar problems. It is found that 

Comsol Multiphysics is efficient in geometric modeling and dealing with a single physics 

problem such as electromagnetic physics. The trends found in the electromagnetism 

simulation using Comsol follow those from the approximate method. The study also 

shows that it is possible to simulate the EMVA under a multiphysics setting. The 

coupling model gives sensible results. However, it is noted that the multiphysics 

simulation demands a steep learning curve and extra effort in model building.
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To build a model in Comsol Multiphysics, several factors have to be considered. 1. 

The geometric shape o f  a model. It is desirable to build a model that is “the same” as the 

real system. But in most cases it is limited by the memory o f the computer. The problem 

“out o f  memory” often happens in a 3-D or coupling model. It is necessary to simplify 

the system such that the model can be run. In this chapter, the electromagnetic coil is 

built as a thin-shell torus. If  the memory had allowed, many thin-shell toruses with 

different inner and external radius would have been built. 2. Determination o f parameters. 

All parameters are supposed to equal to the physical parameters. As the shape o f the 

model is different from the physical one, parameters have to be calibrated again based on 

the analytic and experimental results. 3. To simulate a physical model with an equivalent 

model, “physic conditions” (Comsol menu) should be selected to produce similar 

conditions. In this chapter, a 3-D PMs model and a 2-D PMs o f the coupling model, 

which took the role o f  a 3-D electromagnetic coil with a core, were built by choosing the 

magnetization o f the two PMs such that the magnetic flux density o f these two models 

are the same. 4. The accuracy o f the simulation results o f Comsol M ultiphysics is often 

limited by the mesh selection and the size o f free space. A finer mesh decreases the error. 

But the degree o f meshes is restricted by the computer memory. 5. Many difficulties were 

encountered in building the coupling model. Frequently the inverted mesh problem 

occurs. When working with the Moving Mesh (ALE) application modes to move things 

around, the computational mesh gets deformed. If  the deformations become too large, 

some o f the mesh elements may get inverted. This means that the accuracy o f the solution 

deteriorates and eventually the solution will cease to converge. Sometimes the results 

from the coupling model do not seem to be sensible.
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Chapter 3 

Analytic Study on Non-collocated Vibration Control

In Chapter 2, EMVA is studied. This EMVA will be used in non-collocated vibration 

control. In order to control a non-collocated mass on by EMVA, it is necessary to analyze 

the system.

3.1 Introduction

When a periodic force exerts on a machine, vibration results. The vibration may cause 

damage to the machine. This periodic force may be caused internally (such as the 

imbalance) or externally (such as earthquake). Generally machine vibration affects the 

accuracy and the operation o f the machine. In some extreme situations, if  the machine 

vibrates in resonance, some parts will be overstressed, worn out or even fractured. In 

order to suppress the vibration, various methods are used. One o f  them is vibration 

absorber. When a vibration absorber is directly attached to a body to suppress its 

vibration, a collocated vibration control is obtained. Unfortunately, for some applications, 

it is not possible to collocate the vibration absorber at the location o f  interest. This is 

because vibration absorber is a passive vibration control device which has a narrow 

operation range. Thus it is usually used for suppression o f vibration with a constant 

frequency. I f  the vibration frequency varies, a passive vibration absorber will not provide 

satisfactory performance over the frequency variations o f the excitation. Adaptive- 

passive vibration absorber is a tunable device that is capable o f maintaining the tuning 

condition in the event that the excitation frequency shifts. This chapter reviews the theory 

o f  non-collocated adaptive-passive vibration control [24],

3.2 Vibration Absorber
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As shown in Figure. 3.1 (a), a mass m  is supported by a spring k  and a damper c . 

An external force / ( ( )  = F0 sin{cot) is applied to the mass, where F0 is the magnitude and 

co the excitation frequency. Note that c o - 2 n f  where the unit o f  a> is rad/s and the unit 

o f  /  is Hz (cycle/s).

If  the frequency o f  the external force is equal to the natural frequency o f  the system, 

the system will vibrate in resonance. Under this condition, the displacement o f  the mass 

increases as time goes on, or will develop to infinite if no damping exists between the 

spring and the mass. This system is referred to as primary system.

(«) (b)

Figure 3.1 A  primary system (a) and system with a vibration absorber (b).

As shown in Figure. 3.1 (b), a vibration absorber is attached to mass m. The vibration 

absorber consists o f  a spring ka , a mass ma , and a damper ca . The governing equation 

o f the new system is:

The solution o f  the coupling equations can be separated as two parts: the transient and 

the steady-state. The transient response is not considered here because it dies out rapidly.
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Only the steady-state response is considered. The magnitude o f  the steady-state vibration 

o f the primary mass m , is

(.ka - m ao)2)F0
(3.2)

Note from equation (3.2) that the absorber parameters ka and ma can be chosen such

that the magnitude o f  the steady-state vibration, X, is exactly zero. This is accomplished 

by satisfying the following condition:

Equation (3.3) is referred to as the tuning condition o f a passive vibration absorber.

3.3 Non-collocated Adaptive-passive Vibration Control of a 3-DOF

A 3-degree-of-freedom (DOF) system, which is the primary system, is shown in Figure 

3.2 (a). A force / ( ( )  = F0 sin(a>l) is applied on mass ml . When the excitation frequency 

co is near any o f the natural frequencies o f  the system f i (i = 1 ~ 3), the system vibrates 

at resonance. To control the vibration o f the system, a passive vibration absorber is 

attached to mass m3, as shown in Figure 3.2 (b). The system becomes a 4-DOF system. 

The objective o f the control is to minimize the steady-state vibration o f the non- 

collocated point o f mass mx by adjusting the stiffness o f the vibration absorber ka .

(3.3)

System
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Figure 3.2 The 3-DOF primary system (a) and the system with a vibration absorber (b). 

The governing equation o f the entire system is given as follows:

3 o 0 0  " C y  + C j —z2 0 0 " X y

0 m2 0 0
+

-c. z2 + c3 —c3 0 x 2

0  0 m3 0 x3 0 —c3 c'3 + Ca *3
0 0 0 ma_ 0 0 - c a Ca _ J o

k x + k 2 - k 2 0 0  " 7 ( 0 "
- k 2 k2+k3 “ *3 0 *2 0

0 - * 3 K  + K - K *3 0

0 0 - K 1 3 . 0

+

(3.4)
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To find the amplitude X x o f  the steady-state response o f mass m], Laplace transform 

is used, and the following equation is obtained:

X ( s )  = A-'F(s) (3.5)

where

A =

ml s2 +(cl +c2)s + (kl + k2) - c 2s - k 2 0

- c 2s - k 2 m2 s 1 +(c2 + c3)s + (k2 + k3) - c 3s - k 3

0 -c3s - k 3 m2 s 2 + (c., + ca)s + (k3 + ka)

0 0 - c s - k

X ( s )  =

X x(s)

X 2(s)

X 3(s)

Xa(!)

F(s)

0 
0 
0

a  a

0 

0

- CaS - K

m„s2 +c„s+k„

The transfer function between Ffs^and X ^ s )  o f  mass mx is

F(s) D(s)
(3.6)

where D (s ) = d e t(^ ) , i.e., the determinant o f A , or the characteristic equation (CE) o f  

the system.
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and

m2 s 2 + (c2 + c3)s + (k2 + k3) - c3s - k3

N x(s) = det - c 3s - k 3 m3 s 2 + (c3 + ca)s 4- (k3 +ka) -  c s  -  ka  a

0

0 mas 2+cas+ ka

where N x(s) is the determinant o f a system including the absorber system and the 

intervening structure, i.e., the system involving m2 and m3. This system is called the 

subsystem. When N x(s) is zero, the roots o f this characteristic equation are the natural 

frequencies o f the subsystem, denoted as f si(i = 1 ,2 ,3 ) .

In order to completely attenuate X t (.v), there must exist a real value ka such that

N x(s) is zero for s = jco , where j  = 4 - \ . The equation o f finding the zeros o f N x(s) can 

be rewritten in the form:

1 + ka[(m2ma + m2m3)s4 + (c2ma + c2m3 + c3ma + c3m3 + m2c3)s3 + (k3m3 

+k3ma + k2ma + c2c3 +m2k3+ k2m3 ) s2 + (c2 k3 + k2c3 )s + k2 k3 ] /  Dx (s) = 0

or

l + *aG (j) = 0 (3.9)
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where

D, (5 ) = m2m3mas6 + (c2m3ma + m2c3ma + c3m3ma + m2m3ca + m2cama)s5

+ (c3m3ca + k2m3ma + m2k3ma + m2c3ca + c3cama + c2m3ca + c2c3ma + c2cama + k3m3ma ).s'4

+ (k2cama + k2m3ca + k2c3ma + c2k3ma + L c ama + c2c3ca + kam3ca )s3

+ (c2k3ca + k2k3ma + k2c3ca)s2 + k2k3cas

and

G{s) = [(m2ma +m2m3)s4 +(c2ma +c2m3 +c3ma +c3m3 +m2c3)s3 +(k3m3 

+k3ma + k2ma + c2c3 + m2k3 + k2m3)s2 + (c2k3 + k2c3)s  + k2k3 ] / Dx (s )

The problem can be considered as a typical problem o f root locus, 1 + kaG{s) = 0 . The 

dynamic analysis will proceed as a standard root locus analysis where the system gain to 

be varied is the vibration absorber spring stiffness ka .

In this study, the objective is to suppress the vibration o f  mass ml by changing the 

absorber stiffness ka . The only variant in this subsystem is ka. The system is considered 

as a SISO (Single-Input-Single-Output) system. The transfer function o f  the subsystem 

can be written as

X tt(s) N a(s) F (s)  N a(s)
X ,( s )  F (s ) X x(s) N x(s)

The zeros are the roots o f the characteristic equation o f  the subsystem, meaning that 

when one o f  the subsystem’s frequencies matches the excitation frequency, the 

displacement o f  mass ml is suppressed. The roots are also referred to as anti-resonance 

frequencies o f the new 4-DOF system. If  there exists damping between the absorber and 

other part o f  the subsystem, the vibration magnitude o f  m, cannot be attenuated to zero.
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In order to suppress the vibration o f  mass m, when the frequency o f  the excitation

frequency is equal to one o f  the natural frequencies o f the primary system, the stiffness o f 

the absorber is chosen such that the anti-resonance o f  the new 4-DOF system matches the 

excitation frequency.

3.4 Undamped 3-DOF System

Considering the condition without damping in the system, equation (3.8) becomes to

,  ,  (»!,m + ( f m ,  +  +
1 + ka — —   j ----------- j2— ------— ------------— --- ---------------------------—— — 0  (3 .1 1 )

mas [m2m3s + (k3m3 + m2k3 + k2m3)s + k2k3]

Equation (3.11) can be written in the factored form,

l + k  (m2m3+m2ma)(s + a A)(s + o j c )  Q 

ma(m2m3)s2 (s2 + ct)2B)(s2 + col)

When ka = 0 , equation (3.12) becomes

(s2+co2B)(s2 +G)2D) = 0 (3.13)

When ka = oo, equation (3.12) becomes

(s2 +<yj)(s2 + ^ )  = 0 (3.14)

The case o f  ka = 0 is equivalent to an absence o f  the absorber system. The absorber 

mass ma has no connection with the primary system. The case o f ka = «  is equivalent to 

a rigid connection o f  ma to m3. Under these two bounded conditions, the system in 

Figure 3.2 (b) becomes the systems shown in Figures 3.3 (a) and 3.3 (b), respectively.
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Figure 3.3 (a) ka -  0 ; (b) ka = 0 0 .

Using the values in Table 3.1, when the stiffness changes between ka = 0 and ka = 0 0 , 

frequency response o f mass ml is shown in Figure. 3.4. In Figure 3.4, A, B, C and D 

represent coA, coB, coc and a>D, respectively.

As ka changes from zero to infinity, the natural frequencies o f  the subsystem change in 

the ranges: 0 < cosl < a A , a>B < a>sZ < coc , and coD < cos3 < a>m respectively. When the 

excitation frequency is between the ranges coA <co< coB and coc < co < coD, the vibration 

o f mass ml cannot be suppressed to zero.

51

Reproduced with permission of the copyright owner. Further reproduction prohibited without permission.



10

■210

-310

■410

-510

■610

■710
5 25 30 3510 15 20 40

Frequency (Hz)

Figure 3.4 Frequency response o f  the entire system: solid line, ka =o o ;  dashed line,

3.5 Frequency Response of the Primary System and the System with 
the Vibration Absorber

To better understand the analysis presented in the previous section, various frequency 

responses are computed using the numerical values given in Table 3.1. These parameter 

values are chosen to be as close as possible to a physical model given in the next chapter. 

Figure 3.5 shows the frequency response o f mass m] o f  the primary system. The

primary system has three natural frequencies. In terms o f displacement, the resonance at 

the first natural frequency results in the largest magnitude. The three natural frequencies 

o f the primary system are / j  = 6.59 Hz, / 2 =17.70 Hz, and f 3 =32.15 Hz, respectively.
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Table 3.1 System parameters

Symbol Description Quantity, Unit

m, Mass 2.73 kg

m2 Mass 2.048 kg

m3 Mass 2.635 kg

ma Absorber mass 0.2515 kg

c. Damping coefficient 1 Ns/m

C2 Damping coefficient 1 Ns/m

C3 Damping coefficient 1 Ns/m

Damping coefficient o f absorber damper 0

K Stiffness o f  spring 17183 N/m

k2 Stiffness o f  spring 35401 N/m

K Stiffness o f spring 20616 N/m

K Stiffness o f absorber spring Tunable
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Figure 3.5 Frequency response o f the primary system

Figure 3.6 compares the frequency response \Gn {jco)\ o f  mass m] o f  the primary 

system (solid line) and the frequency responses \Gu (ja>)\ o f  mass mx o f  the entire 

system when /  = f sX (dotted line), /  = f sl (dashdot line), and /  = / l3 (dashed line), 

respectively. These are the lower bounds that can be achieved when ka is tuned in the 

range o f  320 N/m < ka <21200 N /m . It can be seen that with a tuned absorber, the 

amplitude o f  mass ml can be suppressed significantly.
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Figure 3.6 Frequency Response and lower bound o f  the optimum tuning: solid line, 

Primary system response; lower bound response, when f sl = f  (dotted line), f s2 = f  

(dashdot line), and f s3 -  f  (dashed line).

The objective o f adding a vibration absorber is to suppress X { at / ,  ( /  = 1 ~ 3), one o f

the three natural frequencies o f the primary system. The absorber stiffness ka must be set

such that f sl = f . Figure 3.7 shows, as the absorber stiffness ka changes from 0.1 N/m

to 25,000 N /m , the differences between the natural frequencies o f  the subsystem and the 

natural frequencies o f  the primary system, so as to find the optimal stiffnesses o f the 

absorber. The three optimal stiffnesses are represented by three points at which the curves 

cross with x-axis. They are kal -  457 N/m , kal = 2785 N /m , and ka3 = 8963 N /m . As

the stiffness reaches the optimal point, one o f  the natural frequencies o f  the subsystem f si
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matches the natural frequency o f  the primary system f t such that the vibration o f mass 

m] is zero if  the excitation frequency /  equals to f  (/ = 1 ~ 3).

0 0.5 1 1.5 2 2.5
ka (N/m) x1Q4

Figure 3.7 Optimal stiffness for three natural frequencies o f the primary system: dashed 

line, \ f x- f s l \; solid line, \ f 2 - f s2\; dotted line, | / 3 - / j31.

Figures 3.8 shows a comparison o f | Gu (ja>) | o f  the primary system and those o f the 

entire system when f s i= f ,  (z' = l ~ 3 ) .  In each scenario, when one o f the subsystem’s 

natural frequencies f sj (i= l~3) matches one o f the natural frequencies o f  the primary 

system f t (i= l~3), the frequency response o f  the entire system separates into two low 

peaks around the peak f t = f si, and between them there is the anti-resonance point.
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Figure 3.8 | Gxx(jco)\ o f  the primary system and o f  the entire system as f sX = f  (dotted 

line), f sX = f x (dashdot line), and f sX = f x (dashed line).
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Chapter 4 

Experimental Studies

The previous chapter has analyzed a 3-DOF primary system and found that the 

vibration o f  mass ml is suppressed when one o f  the natural frequencies o f  the subsystem

equals to the excitation frequency. This chapter is devoted to implement the non- 

collocated vibration using the modified EMVA.

4.1 Description of the Experimental Setup

Figure 4.1 shows the experimental system which includes five parts: primary system, 

absorber system, data collection system, computer control system, and shaker system.

Absorber System

Primary
System

Accelerometer Cuirent Regulator

Amplifier

Shaker

Data
Collection
System

Computer
Control
systemAmplifier

Figure 4.1 Experiment system

Figure 4.2 is a photograph o f the experiment model. The primary system is formed by 

two vertical aluminium plates and three aluminium slabs. The slabs are fastened between 

the two plates by bolts. The structure is fastened to a base (see Figure 4.3). The absorber

58

Reproduced with permission of the copyright owner. Further reproduction prohibited without permission.



system, which has been described in Chapter 2, is fastened on the top o f the third 

aluminium slab.

Figure 4.2 Photograph o f  the experiment model.
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-Absorber

-The Third Slab

-The Second Slab

Alum inium  Plate

Shaker

Figure 4.3 CAD drawing o f the entire System

The data collection system includes an accelerometer (Brtiel & Kjaer 4393 V) and a 

charge amplifier (Brtiel & Kjasr 2692). The accelerometer is placed on mass m, to 

measure its vibration and the signals are fed into the charge amplifier. The charge 

amplifier is used to condition the acceleration signals.

The computer control system consists o f  a Date Acquisition (DAQ) Board (DS1102 

dSpace) and a microprocessing computer. The latter, a Pentium III (550 MFIz) PC, is 

used to control the system. The dSPACE ControlDesk provides a graphic user interface 

with Matlab, Simulink and the DAQ board.

The shaker system includes a power amplifier (Brtiel & Kjaer 2706) and an 

electromagnetic coil. An excitation signal generated and controlled by the control system 

is sent to the power amplifier. A controlled periodic current (DC) is sent from this power 

amplifier to the electromagnet coil. The interaction between the electromagnet coil and a 

permanent magnet glued on mass mx produces a non-contact excitation force.
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4.2 Identification o f the Parameters o f the Primary System

The values o f masses mx , m2 , and m3 can be easily found to be mx = 2.73 kg ,

m2 =2 .048  kg , and m3 =2.635 kg . In order to find the equivalent stiffnesses kx, k2,

and k3, impact tests were conducted. Figure 4.4 shows a typical Fast Fourier transform

(FFT) spectrum o f  mass mx ‘s response to an impact. The sampling time o f  the FFT

system is 0.001 second.

From Figure 4.4, the three natural frequencies o f the primary system were found to be 

/ ;  = 6 .59  Hz, f 2 =17.7 Hz and f 3 =32.15 Hz.

10

010

110'

500 5 30 40 4510 15 20 25 35
Frequency (Hz)

Figure 4.4 FFT spectrum o f  the response o f  mass mx o f  the primary system to an impact

In order to find kx, k2, and k3, a nonlinear optimization was employed. If  trial values 

k[ , k ‘2, and k3 are given, estimated natural frequencies can be found by solving the 

following eigenvalue problem
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d e t [ K ' - ( 2 7 t f f  M ]  = 0 ,  / = 1 ,2 ,3 (4.1)

Solving Equation (4.1) results in three estimated frequencies f , \  i = 1,2,3 corresponding 

to the trial values k[ , k2 and k l .

K + K - K 0

K ‘ = - K K + K - K
0 - K K

mx 0 o ' '2 .73 0 0

M = 0 m2 0 = 0 2.048 0

0 0 m3_ 0 0 2.635

A cost function is defined as:

K ) M l z A M L A + \ I L A  (4,)
f \  f 2 f 2

where f n  i = 1,2,3 are the natural frequencies obtained by impact testing.

The problem can be solved by Nelder-M ead sequential complex method [34]-[35]. The 

sequential simplex method employs geometric properties o f the n -dimensional space. 

First the cost functions at the n +1 comer points are evaluated to form a simplex. Second 

a new simplex is formed by replacing the point with the highest function value with a 

newly selected point. And the process repeats. The iteration continues again until the cost 

function reaches the convergence criterion.

This problem has 3 variables kx , k2, and k2 , so 4 corners are required to form a 

simplex by selecting 4 groups o f stiffness. They are presented as:
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JfO_rrO L-0 h-0 1? K °~[k° k° k° T  K°~ ik° k° k° V 311(1
1 1 * 1 (1 ) * 2 (1 )  * 3 ( 1 )1  ’ 2 L 1(2) * 2 ( 2 )  * 3 ( 2 ) 1  > -**■ 3 ~  L * l(3 )  * 2 ( 3 )  * 3 ( 3 ) 1  a U U

JfO_r£° 1-0 lO n7 
4 i-rt'l(4 ) 2(4) * 3 (4 )1

where superscript denotes the number o f  iteration, the first subscript denotes the stiffness 

o f each spring while the subscript inside the brackets denotes the corner number. The 

iteration terminates when a certain criteria is satisfied: J (k v  k2, k3) < 0.0005. Different

initial simplex values o f k[ , k\ , and k !3 are tried to get the final results, see Table 4.1.

Table 4.1 Initial simplexes vs. the optimal results

Initial simplex K k2 K J

1 ^  = [20,000 30,000 3 0 ,000 f 

t f °2 = [30,000 20,000 15,000]r 

^ 3  = [35,000 25,000 3 5 ,000 f 

J fj  = [30,000 16,000 2 0 ,0 0 0 f

17184 35401 20616 7.923 xlO "9

^ - [ 2 0 ,0 0 0  33,000 3 0 ,0 0 0 f 

K°2 = [32,000 20,000 15 ,000f 

if® = [30,000 25,000 3 5 ,000 f 

K°4 = [30,000 16,000 20 ,000]r

17183 35401 20616 4.863x10^

H° = [20,000 23,000 2 9 ,0 0 0 f 

K “=[30,000 20,000 4 5 ,0 0 0 f 

^ 3  = [35,000 15,000 3 5 ,0 0 0 f 

H° = [40,000 19,000 2 2 ,0 0 0 f

17183 35400 20617 1 .533xl0 " 5

This method is realized by programming the algorithm in Matlab. The three different 

groups o f the initial values result in almost identical results. The stiffnesses o f  the 

primary system were chosen to be kx =17183 N /m ,/t2 =35400 N /m , k3 = 20617 N /m .
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4.3 Vibration Suppression Using Manual Adjustment

The EMVA, discussed in Chapter 2, is used as the vibration absorber. The absorber is 

designed to have a mass o f ma -  0.2515 kg . To suppress the vibration o f  mass mx, the 

absorber needs to be adjusted to a certain stiffness such that one o f  the natural 

frequencies o f  the subsystem f si ( i = 1 ~ 3 ) equals the excitation frequency / .  The

objective o f using the EMVA is to suppress the vibration o f mx when the system is

excited at /  = f x , f 2 , or / 3 , i.e., the natural frequencies o f the primary system,

respectively. Following the analysis in Chapter 3, kaX = 457 N/m will result in f sX= f x,

kaX = 2785 N/m will lead to f s2 = f 2 , and ka3 = 8963 N/m will yield f sj = / 3 . Under

these conditions, the natural frequencies o f  the absorber itself would be f aX = 6.747 Hz,

f a2 = 16.569 Hz and f a2 = 29.256 Hz, respectively.

To find the natural frequency o f the absorber, the primary system was fastened to the 

base by a rigid triangle frame. By impacting the absorber mass and collecting its 

acceleration signals and applying the FFT, the natural frequency f a was found.

Experiment showed that when the absorber was set to be f aX = 6.747 Hz, the PM

deflected away from the equilibrium position and the absorber spring was so soft that the 

PM was stuck on one side o f the electromagnet. As a result, the absorber cannot be used 

to attenuate the vibration o f mass mx when the excitation frequency is equal to the first 

natural frequency o f  the primary system. Due to this limitation, this study deals with only 

the second and third natural frequencies o f the primary system. Section 3.5 has shown 

that the absorber stiffness needed to suppress X x, the vibration o f  mass mx, at /  = f 2 is

significantly different from the one needed to suppress X x at /  = / 3 . This requires the

tunable absorber to have a large tuning range. However, normally an online tunable 

vibration absorber has a limited tuning range. For example, the EMVA used in [26] and 

[36] has about 5 Hz tuning range when the current varied from -2.3 A to 2.3 A. For this 

purpose, the EMVA developed in [26] and [36] was modified to provide both manual
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tuning and online tuning, as shown in Figure 2.2 in Section 2,2 o f Chapter 2. Figure 4.5 

shows the modified EMVA.

v

Y  '

Figure 4.5 Photograph o f the modified EMVA

Figure 4.6 and Figure 4.7 show the response o f  mass mx to an impact testing as 

f s2 = f 2 (as f a2 = 16.569 Hz) and f s3 = f 3 (as f a3 =29.256 Hz). When the absorber was 

set to a point such that one o f the natural frequencies o f  the subsystem was the same as a 

natural frequency o f the primary system f sj = f t (/ = 1 ~ 3), the vibration o f mass mx was 

drastically suppressed when the excitation frequency was the same as the subsystem. In 

other words, mass mx was at its lowest magnitude when the anti-resonance frequency 

was just the same as the excitation frequency. The magnitude increased as the excitation  

frequency drifted from the anti-resonance. Due to damping between the absorber and 

other element, the magnitude o f mass mx could not be zero.
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Figure 4.6 FFT spectrum o f  an impact response o f mass mx when the EM VA is tuned 

such that f s2 = f z .
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Figure 4.7 FFT spectrum o f  an impact response o f  mass mx when the EM VA is tuned 

such that f s3 = f 3.
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When the manually preset point o f  the absorber was at f a2 -1 6 .5 6 9  Hz, the second 

natural frequency o f the subsystem was the same as the second natural frequency o f the 

primary system. When the excitation frequency /  was the same as the second natural 

frequency o f  the primary system ( /  = f 2), the vibration o f mass mi was attenuated to 

minimum. The range o f  the natural frequency o f the absorber varied from 

f a2mm =13.184 Hz to / a2max =20.264 Hz as the current to the EMVA was changed

from -2 .3  A to 2.3 A . On the other hand, when the excitation frequency /  was 

around the third natural frequency o f  the primary system ( /  = / 3), the absorber had to be 

/ o3 = 29.256 Hz such that the third natural frequency o f the subsystem was the same as 

the third natural frequency o f the primary system. The absorber had to be manually 

adjusted to be f a3 to suppress the vibration o f mass m{ as the excitation frequency is 

around the third natural frequency o f  the primary system.

4.4 The EMVA Calibration

Once the absorber was manually preset close to a required point, the EM VA could be 

adjusted by changing the current to the electromagnet. To find the relationship between 

the absorber frequencies f a l , f a3 and the current I , the primary system was fastened to 

the base by a rigid triangle frame. Impact testing was also used to obtain the natural 

frequencies f a2 and f a3 when the current was varied. The currents to the electromagnet 

changed in three stages: stepped up from 0 A to 2.3 A, stepped down to -2.3 A, then 

stepped up to 2.3 A. For each given current, the absorber mass was tapped and the 

acceleration signals o f the absorber mass were recorded. The natural frequencies f a2 and

f a3 were found through applying FFT to the measured response. Figure 4.8 shows the 

relationship between the absorber frequency f al versus the loading and unloading o f the 

coil current and Figure 4.9 shows the relationship between the absorber frequency f a3 

versus the loading and unloading o f  the coil current. The dots represent f aj and the solid 

lines represent a third-order polynomial curve-fit o f  the average results when the current
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changed from 0 to 2.3 A, from 2.3 A to -2.3 A, and from -2.3 A to 2.3 A. Because o f  the 

nature o f  the steel core, the results exhibited the characteristics o f  slight hysteresis. At the 

preset value f a2 = 16.569 Hz, the variation range o f  f a2 is between 13.184 Hz and

20.020 Hz. As for f a% -  29.256 Hz, the range is between 27.832 Hz and 31.494 Hz when 

the current varies.

-2.5 - 0 .5 0.5 2.5

Figure 4.8 Absorber frequency versus the coil current with current loading and current 

unloading when f a was preset to be 16.569 Hz manually.
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Figure 4.9 Absorber frequency versus the coil current with current loading and current 

unloading when f a was preset to be 29.256 Hz manually.

4.5 The EMVA Performance when Attached to the Primary System

It is desired to know the EMVA adjustment range when it is attached to the primary 

system and the current o f  the electromagnet varies. It was done by a sinusoidal sweeping 

experiment. After the EM VA was manually tuned such that f a2 =16.569 Hz which 

results in f s2 = f 2, mass ml was excited by a sinusoidal force. Then the magnitude o f  the 

steady-state response was measured. Next, the excitation frequency was increased by 

1 H z , the process was repeated. As a result the relationship between the magnitude o f 

the steady-state response and the excitation frequency was found. Now, the current o f the 

electromagnet was set to be -2.3 A, the process was repeated. The same procedure was 

conducted with a current o f 2.3 A. Figure 4.10 shows the results. It can be seen that when 

the current is -2 .3  A, the anti-resonance shifts to the left, and when the current is 2.3 A , 

the anti-resonance shifts to the right. This indicates that the EMVA adjustment range is 

about 4 Hz (from 15 Hz to 19 Hz) when the current varies from -2 .3  A to 2.3 A . The
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natural frequency o f  the absorber f a2 =16.569 Hz is within the range o f the anti­

resonance.

As the EMVA was manually tuned such that f a3 = 29.256 Hz which results in / s3 = / 3, 

mass ml was excited at a sinusoidal force. The same testing was repeated. Figure 4.11 

shows the results. It can be seen that when the current is -2 .3  A, the anti-resonance shifts 

to the left, and when the current is 2.3 A, the anti-resonance shifts to the right. The 

EMVA adjustment range is about 2 Hz (from 31 Hz to 33 Hz) when the current varies 

from -2 .3  A  to 2.3 A. The natural frequency o f  the absorber / o3 = 29.256 Hz is outside 

o f the range o f  the anti-resonance.
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o
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Figure 4.10 Magnitude o f  the steady-state acceleration signal versus the excitation 

frequency when the system is excited by a sinusoidal force and f a2 is manually tuned to

be f a2 =16.569 Hz: dashed line, I  = -2 .3  A ; solid line, 7 = 0 ; dotted line, I  -  2.3 A .

70

Reproduced with permission of the copyright owner. Further reproduction prohibited without permission.



-1  ' 1 ‘ 1 1 1------------------------
28  29  30 31 32 33 34  35

Frequency (Hz)

Figure 4.11 Magnitude o f the steady-state acceleration signal versus the excitation 

frequency when the system is excited by a sinusoidal force and f a3 is manually tuned to

be f a2 = 29.256 Hz: dashed line, I  = -2 .3  A ; solid line, 1 = 0; dotted line, I  = 2.3 A .

4.6 The EMVA Calibration

The EMVA can be manually adjusted and used to suppress the vibration o f mass mx 

when a natural frequency o f  the subsystem equals to the excitation frequency f si = f  

( i  -  2 ~ 3). I f  the excitation frequency varies, the new system may be in resonance again. 

The EM VA’s capability o f on-line tuning offers a solution to ensure the tuning condition 

in the event that the excitation frequency varies. The objective o f the on-line tuning is to 

adjust the current o f the EMVA such that the natural frequency f s2 or / t3 o f  the

subsystem equals the excitation frequency.

To this end, the relationship between the current I  and f s2 or f s3 is needed. In

Section 4.4, the relationships between the current I  and f a have been found

experimentally. Using the average o f the values for current stepping up and the values for
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current stepping down, a third-order polynomial curve fit equation is obtained. The 

equation is, for f a =16.569 Hz

/  = -43 .204+  6 .7045/, - 0 .3 7 3 6 / /  + 0 .0 0 7 6 // (4.4)

and for f a = 29.256 Hz

1 = 3 0 9 .0 2 -3 5 .122/a + 1 .2 7 0 0 / / -0 .0 1 4 7 /a3 (4.5)

Figure 4.12 shows as the absorber was at the preset point f a = 16.569 Hz the 

relationship between the current I  and the natural frequency o f  the absorber f a by taking 

into consideration o f  the average results as the current stepped down from 2.3 A to 

-2 .3  A and stepped up from -2.3 A to 2.3 A. The solid line is obtained by applying the 

third-order polynomial curve-fit o f  the average results. The circles represent the average 

results o f  the current and the natural frequency o f the absorber. Figure 4.13 shows as the 

absorber was at the preset point f a -  29.256 Hz the relationship between the current and

the natural frequency o f the absorber by taking into consideration o f the average results 

as the current stepped down from 2.3 A to -2.3 A and stepped up from -2.3 A to 2.3 A. 

The solid line is obtained by applying the third-order polynomial curve-fit o f  the average 

results. The circles represent the average result o f  the current and the natural frequency o f  

the absorber.
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Figure 4.12 Relationship between the current and the natural frequency o f the absorber 

when / a =16.569 Hz.

31.5

N
X

>*ocsO'
£

j. Q P v jO£>cp>x " _ _

o(A
<  28.5

27.5
- 0.5 2.5- 2.5 0.5

Current I (A)

Figure 4.13 Relationship between the current and the natural frequency o f the absorber 

when f a = 29.256 Hz.
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As the relationship between the current I  and the natural frequency o f  the absorber f a 

is known, the stiffness o f  the absorber corresponding to current I  is obtained by

*fl= (2  n f a)2ma (4.6)

Then the natural frequencies o f the subsystem f sj ( i = 1 ~ 3) are decided by 

d e t[K s - ( 2 n / J 2M s] = 0 (4.7)

where

h + K  - K 0

K s = - * 3  k2 + ka - K

1 0 1 K

M
m2
0

0

0

m.
0

0

m„

The relationship between the current I  and the natural frequencies o f the subsystem is 

built by applying the third order polynomial curve-fit o f  the average result o f  current and 

f si . Figure 4.14 shows the third-order polynomial curve-fit o f  the second natural

frequency o f  the relationship between I  and f s2 when f a is manually preset to be 

f a - 16.569 Hz. When the current /  changes from -2.3 A to 2.3 A, the second natural 

frequency f s2 o f the subsystem changes from 14.300 Hz to 21.090 Hz. The best fit curve 

equation is given as

I  = -58.529 + 8.807f s2 -  0.4686 f J  + 0.0089f j  (4.8)
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Figure 4.14 The best-fit curve o f  the second natural frequency o f the subsystem and the 

current o f  the electromagnet

Figure 4.15 shows the third-order polynomial curve-fit o f  the relationship between I  

and f s3 when f a is manually preset to be f a -  29.256 FIz. When the current changes

from -2.3 A to 2.3 A, the third natural frequency f s3 o f  the subsystem changes from

30.350 Hz to 33.500 Hz. The best fit curve equation is given as

I  = -339.36 + 25 .779/j3 -0 .6 5 9 3 f 2 + 0 .0058/s33 (4.9)

It is noted that as the natural frequency o f the absorber f a =16.569 Hz is within the 

adjusting range o f the anti-resonance o f  the entire system, but the natural frequency o f the 

absorber f a = 29.256 Hz is not in that o f  the entire system.
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Figure 4.15 The best-fit curve o f  the third natural frequency o f  the subsystem and the 

current o f  the electromagnet

4.7 Experimental Results

Three control methods were tested experimentally. The first one is a FFT-based 

method. The second one is the FFT-based plus fine tuning. The third one is a response 

root-mean-squares (RMS) based method. Each method and the results will be presented 

as follows.

4.7.1 Simulink Model for the FFT-based Tuning Method

The FFT-based method applies the FFT to the measured response o f  mass ml to find 

the frequency o f the highest peak in the FFT spectrum. This frequency is then considered
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to be the excitation frequency and used in Equation (4.8) or (4.9) to determine the desired 

current in order to tune the EMVA.

Figure 4.16 shows a Simulink model for the FFT-based method. The Excitation 

Subsystem generates a sinusoidal signal. The signal is sent to a digital to analog channel, 

DAC #1. The analog signal from DAC #1 is fed into a power amplifier to drive the 

shaker. The acceleration signal measured by an accelerometer is sampled at an analog to 

digital channel ADC #1. An S-function Buffer is used to collect a specified length o f  data. 

In this case the data length used is 2048. The sampling time used is 0.001 second. Zero- 

Order Hold 2 executes every 2.048 seconds. FFT block, an S-function executing every

2.048 seconds, outputs frequency o f the response. The Compute_current block calculates 

the output current either by equation (4.8) or (4.9) according to the input frequency. 

Saturation limits the output current to the DS1102DAC such that the current applied to 

the EMVA does not exceed ±2.3 A , which is the maximum allowed current to the coil 

o f  the EMVA.

G a inZ er o -O r d e r  

Holdl :E x c ita t io n  S y s te m S c o p e 2

G ro u n d T e r m in a to r

S a tu r a t io n

D S 1 1 0 2 D A C D S 1 1 0 2 A D C

Source

I-----------------------1 Z ero -O rd er
S -F u n c t io n  B u ild e r  H o ld 2

FFT

o
C o m p u te _ c u r r e n t

DAC #3

DAC 9 4

DAC

DAC n ADC 92

S * F u n c tio n  B u ild e r 2

Figure 4.16 Simulink model for the FFT-based tuning.

When experiment conditions change, the relationship between the current and the 

stiffness o f  the system will not be the same, such as variation o f  the coil resistance o f  the 

EMVA due to different temperature. Under these conditions, the relationship built in 

equations (4.8) and (4.9) may not be accurate for the vibration attenuation. It is necessary
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to use an adjusting controller to cope with the variable conditions. Figure 4.17 shows the 

FFT-based plus fine tuning model. By adding a Fine control block between 

Compute_current block and Saturation block in Figure 4.16, this new model is formed. 

The Fine_control block, an S-function, is to adjust the current in fine steps. The block 

considers the measured frequency and root mean squared value (RMS). The RMS value 

is calculated as

rms = /=1

N

where N  is the number o f  measured points in the sampled period, or 2.048 second. When 

the RMS value exceeds a prescribed threshold value, the current is adjusted according to 

the FFT-based method. When the RMS value is below the threshold value, the current is 

adjusted by the following way. The present RMS value is compared with the previous 

RMS value. If  the RMS value is increased due to increasing (or decreasing) the current, 

the current is decreased (or increased) by a prescribed increment. I f  the RMS value is 

decreased due to decreasing (or increasing) the current, the current is decreased (or 

increased) by the prescribed increment.
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Figure 4.17 Simulink model for the FFT-based plus fine tuning method

Figure 4.18 shows the Simulink model developed for the RMS auto-tuning method. 

The signal measured by the accelerometer is discretized by Zero-Order Hold 2 with a 

sampling time of 0.001 second. The S-function Buffer is used to collect a length o f 512 

data. Zero-Order Hold 3 executes every 0.512 seconds. RMS block, an S-function 

executing every 0.512 seconds, outputs RMS o f the acceleration signals. The 

RMS_analyzer block analyzes the RMS value and its change direction, and outputs 

current according to these two factors. I f  the value o f RMS is smaller than the threshold, 

the output current remains unchanged. If  the value o f  RMS exceeds the threshold, the 

output current is changed according to the value o f RMS change. If  the value o f  RMS 

increases (or decreases) due to decreasing (or increasing) the current, the current is 

increased (or decreased) by a prescribed value. If  the value o f RMS decreases (or 

increases) due to increasing (or decreasing) the current, the current is decreased (or 

increased) by a prescribed value.
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Figure 4.18 Simulink model for the RMS-based tuning method

Two testing scenarios were devised to test the effectiveness o f the EMVA in dealing 

with variable excitation frequencies. The following sections describe the testing scenarios 

and results.

4.7.2 Testing Scenario One

In scenario one, the EMVA was manually preset such that the second natural 

frequency o f  the subsystem equals the second natural frequency o f the primary system, 

i.e., f s2-  f 2 =17.700 Hz or f a =16.569 Hz. The excitation frequency was changed in 

three steps. First, the excitation frequency was set to be /  = 17.700 Hz. After 6.7 seconds, 

the excitation frequency was switched to be /  = 18.860 Hz which was close to the third 

natural frequency o f  the entire system. At around t = 16.7 second, the excitation 

frequency was changed to be /  = 16.240 Hz which was close to the second natural 

frequency o f  the entire system. I f  the EMVA is used as a passive vibration absorber, the 

system will be at the anti-resonance during the first 6.7 seconds, at the resonance at the
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Figure 4.19 Experimental results using the FFT-based method when the absorber was 

manually preset at f a2 = 16.569 Hz: (a) response o f mass ml without control, (b)

response o f  mass ml with control, (c) the frequencies: solid line, excitation frequency; 

dashed line, estimated frequency, (d) the EMVA current.

Figure 4.20 shows the results when the FFT-based plus fine tuning with a small 

threshold was applied. The threshold was 0.005 and the fine current increment was 0.2. 

Figure 4.20 (a) shows the response o f mass m, without control. Figure 4.20 (b) shows the 

response o f  mass ml when the EMVA was activated. Figure 4.20 (c) shows the variation

o f the excitation frequency and the estimated excitation frequency. Figure 4.20 (d) shows 

the current to the EMVA. As shown in the figure, the response was small and the current 

was low during the first 6.7 seconds because the system was at the anti-resonance state. 

After the system was set into the resonance at t  -  6.7 second, the response was increased. 

It took 2.048 seconds for the control system to activate the EMVA. After the EMVA was
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tuned so that f s2 = f 2 , the response was reduced. At / = 16.7 second, the excitation

frequency varied. Once again it took 2.048 seconds for the control system to respond to 

this change. Based on the identified excitation frequency, the EMVA current was 

adjusted to the desired one so that the response was suppressed again. As the RMS value 

was always greater than the threshold, the fine tuning was not activated and the tuning 

was determined by the FFT-based method.
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Figure 4.20 Experimental results using the FFT-based plus fine tuning with a small 

threshold when the absorber was manually preset at f a2 =16.569 Hz: (a) response o f

mass mx without control, (b) response o f mass mx with control, (c) the frequencies: solid 

line, excitation frequency; dashed line, estimated frequency, (d) the EMVA current.

Figure 4.21 shows the results when the FFT-based plus fine tuning when a proper 

threshold was used. The threshold was set to be 0.051 and the fine current increment was 

0.2. Figure 4.21 (a) shows the response o f mass mx without control. Figure 4.21 (b)
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shows the response o f mass m, when the EMVA was activated. Figure 4.21 (c) shows the 

variation o f  the excitation frequency and the estimated excitation frequency. Figure 4.21 

(d) shows the current to the EMVA. As shown in the figure, the response was small and 

the current was low during the first 6.7 seconds because the system was at the anti­

resonance state. After the system was set into the resonance at / = 6.7 second, the 

response was increased. It took 2.048 seconds for the control system to activate the 

EMVA. After the EMVA was tuned so that f s2 -  f 2 , the response was reduced. At

t = 16.7 second, the excitation frequency varied. Once again it took 2.048 seconds for the 

control system to respond to this change. Based on the identified excitation frequency, 

the EMVA current was adjusted to the desired one to suppress the vibration. The fine 

tuning changed the current in a small step to reduce the vibration further.
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Figure 4.21 Experimental results using the FFT-based plus fine tuning with a proper 

threshold when the absorber was manually preset at f a2 =16.569 Hz: (a) response o f

mass ml without control, (b) response o f mass ml with control, (c) the frequencies: solid 

line, excitation frequency; dashed line, estimated frequency, (d) the EMVA current.
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Figure 4.22 shows the results when the FFT-based plus fine tuning with a large 

threshold was applied. The threshold was set to be 0.5 and the fine current increment was

0.8. Figure 4.22 (a) shows the response o f  mass without control. Figure 4.22 (b)

shows the response o f  mass mx when the EMVA was activated. Figure 4.22 (c) shows the

variation o f  the excitation frequency and the estimated excitation frequency. Figure 4.22 

(d) shows the current to the EMVA. As shown in the figure, the response was small and 

the current was low during the first 6.7 seconds because the system was at the anti­

resonance state. After 2.048 seconds, the fine tuning began to adjust the EMVA by 

increasing the current and the action caused the increase o f the response. Then the fine 

tuning adjusted the EMVA back to zero current after sensing the increase o f the response. 

The fine tuning continued increasing the current in another direction and changed the 

current to negative. As the system was set into the resonance at / = 6.7 second, the 

response was increased. It took 2.048 seconds for the control system to re-activate the 

EMVA. The current changed in the direction o f decreasing the response. In this situation, 

because the RMS value was always smaller than the threshold, the EM VA current was 

adjusted according to the fine tuning scheme only.
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Figure 4.22 Experimental results using the FFT-based plus fine tuning with a larger 

threshold when the absorber was manually preset at f a2 =16.569 Hz: (a) response o f 

mass mx without control, (b) response o f mass ml with control, (c) the frequencies: solid 

line, excitation frequency; dashed line, estimated frequency, (d) the EMVA current.

Figure 4.23 shows the results when the RMS-based method was applied. The threshold 

was 0.051 and the fine increase was 0.5. Figure 4.23 (a) shows the response o f  mass m,

without control. Figure 4.23 (b) shows the response o f mass mx when the EMVA was 

activated. Figure 4.23 (c) shows the variation o f the excitation frequency. Figure 4.23 (d) 

shows the current to the EMVA. As shown in the figure, the response was small and the 

current was around zero at first because the system was at the anti-resonance state. After 

the system was set into the resonance at t = 6.7 second, the value o f RMS was increased 

significantly. It took 0.512 second for the control system to react and the current changed 

suddenly. Then the response was reduced gradually. At t = 16.7 second, the response was 

increased again. It took 0.512 second for the control system to respond to this change.
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Based on the value o f RMS, the EMVA current was decreased to suppress the response 

again. The RMS-based method took longer time to reach the final adjustment than the 

other two methods.

15 20 25
Time (s)

Figure 4.23 Experimental results using the RMS-based method when the absorber was 

manually preset at f a2 - 16.569 Hz: (a) response o f  mass mi without control, (b) 

response o f mass ml with control, (c) the excitation frequency, (d) the EMVA current.

4.7.3 Testing Scenario Two

In scenario two, the EMVA was manually preset such that the third natural frequency 

o f  the subsystem equals the third natural frequency o f  the primary system, i.e., 

f s3 = / 3 =31.740 Hz or f a =29.256 Hz. The excitation frequency was changed in three 

steps. First, the excitation frequency was set to be /  = 31.740 Hz. After 6.7 seconds, the 

excitation frequency was switched to be /  = 33.450 Hz which was close to the fourth
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natural frequency o f the entire system. At around r = 16.7 second, the excitation 

frequency was changed to be /  -30 .280  Hz which was close to the third natural 

frequency o f  the entire system. If  the EMVA is used as a passive vibration absorber, the 

system will be at the anti-resonance during the first 6.7 seconds, at the resonance at the 

fourth natural frequency during the next 1 0  seconds, and at the resonance at the third 

natural frequency during the rest o f  the time.

Figure 4.24 shows the results when the FFT-based method. Figure 4.24 (a) shows the 

response o f  mass m, without control. Figure 4.24 (b) shows the response o f mass ml

when the EMVA was activated. Figure 4.24 (c) shows the variation o f the excitation 

frequency and the estimated excitation frequency. Figure 4.24 (d) shows the current to 

the EMVA. As shown in the figure, the response was small and the current was low at 

first. But due to the change o f the measured frequency, the current changed. After the 

system was set into the resonance at r = 6.7 second, the response was increased 

significantly. It took 2.048 seconds for the control system to activate the EMVA. After 

the EMVA was tuned so that f s3 = / 3, the response was reduced. At t = 16.7 second, it

took 2.048 seconds for the control system to respond to this change. The change o f 

current also caused the system to change and this transient response made the current 

changed again. Based on the identified excitation frequency, the EMVA current was 

adjusted to the desired one so that the response was suppressed again.

88

Reproduced with permission of the copyright owner. Further reproduction prohibited without permission.



ajcCT>
C0
CO

1  0.1
Q O <

4 V H I

0

- 0.1

<b> _

0 10 15 20 25 30 35 40

S'c<D
2C
CD

<
c .<d\—
L_
2
o

2.5
1
0

-1
-2.5

I Q
_

" I  ' I I I ..........

! .........J _ _  . .  I . " n - — ,-----------------------------,----------------------------- ,------------------------ ----

0 10 15 20 25
Time (s)

30 35 40

Figure 4.24 Experimental results using the FFT-based method when the absorber was 

manually preset at f a3 = 29.256 Hz: (a) response o f mass ml without control, (b) 

response o f  mass mx with control, (c) the frequencies: solid line, excitation frequency; 

dashed line, estimated frequency, (d) the EMVA current.

Figure 4.25 shows the results when the FFT-based plus fine tuning with a small 

threshold was applied. The threshold was 0.005 and the fine increase was 0.2. Figure 4.25

(a) shows the response o f  mass mx without auto-tuning. Figure 4.25 (b) shows the

response o f  mass m, when the EMVA was activated. Figure 4.25 (c) shows the variation

o f  the excitation frequency and the estimated excitation frequency. Figure 4.25 (d) shows 

the current to the EMVA. As shown in the figure, the response was small and the current 

was around zero at first. After the system was set into the resonance at t = 6.7 second, the 

response was increased. It took 2.048 seconds for the control system to activate the 

EMVA. After the EMVA was tuned so that f s3 = f 3, the response was reduced. At
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t = 16.7 second, the excitation frequency varied. Once again it took 2.048 seconds for the

control system to respond to this change. Based on the identified excitation frequency, 

the EMVA current was adjusted to the desired one so that the response was suppressed 

again. As the RMS value was always greater than the threshold, the fine tuning did not 

work. The tuning was determined by the FFT-based method.

|l m I"    ..

15 20 25
Time (s)

Figure 4.25 Experimental results using the FFT-based plus fine tuning with a small 

threshold when the absorber was manually preset at f a3 =29.256 Hz: (a) response o f

mass ml without control, (b) response o f mass m{ with control, (c) the frequencies: solid

line, excitation frequency; dashed line, estimated frequency, (d) the EMVA current.

Figure 4.26 shows the results when the FFT-based plus fine tuning when a proper 

threshold was applied. The threshold was set to be 0.051 and the fine current increment 

was 0.2. Figure 4.26 (a) shows the response o f mass m1 without control. Figure 4.26 (b)
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shows the response o f  mass ml when the EMVA was activated. Figure 4.26 (c) shows the 

variation o f the excitation frequency and the estimated excitation frequency. Figure 4.26 

(d) shows the current to the EMVA. As shown in the figure, the response was small and 

the current was low during the first 6.7 seconds because the system was at the anti­

resonance state. The current was adjusted around t = 2.048 second by the fine tuning to 

decrease the response. After the system was set into the resonance at t -  6.7 second, the 

response was increased. It took 2.048 seconds for the control system to activate the 

EMVA. After the EMVA was tuned so that f s3 = f 3 , the response was reduced. At

/ = 16.7 second, the excitation frequency varied. Once again it took 2.048 seconds for the 

control system to respond to this change. Based on the identified excitation frequency, 

the EMVA current was adjusted to the desired one to suppress the vibration. The fine 

tuning then changed the current in a small step to reduce the vibration further.
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Figure 4.26 Experimental results using the FFT-based plus fine tuning with a proper 

threshold when the absorber was manually preset at f a3 = 29.256 Hz: (a) response o f

mass m{ without control, (b) response o f mass m] with control, (c) the frequencies: solid

line, excitation frequency; dashed line, estimated frequency, (d) the EMVA current.

Figure 4.27 shows the results when the FFT-based plus fine tuning with a large 

threshold was applied. The threshold was set to be 0.5 and the fine current increment was

1. Figure 4.27 (a) shows the response o f  mass m, without control. Figure 4.27 (b) shows 

the response o f  mass m, when the EMVA was activated. Figure 4.27 (c) shows the

variation o f the excitation frequency and the estimated excitation frequency. Figure 4.27 

(d) shows the current to the EMVA. As shown in the figure, the response was small and 

the current was low at first because the system was at the anti-resonance state. At t=\ 

second, the fine tuning began to adjust the EMVA by increasing the current and the 

response increased. Then the fine tuning adjusted the current after sensing the increase o f 

RMS. The current changed in another direction and returned the current to zero. As the
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system was set into the resonance at t = 6.1 second, the response was increased. It took

2.048 seconds for the control system to re-activate the EMVA. The current changed when 

tracking the direction o f decreasing the value o f  RMS. At t = 16.7 second, the excitation 

frequency changed again. As the current changed in the direction to decrease the response, 

the current increased further. In this situation, because the RMS value was always smaller 

than the threshold, the EMVA current was adjusted by the fine tuning only.

15 20 25
Time (s)

Figure 4.27 Experimental results using the FFT-based plus fine tuning with a large 

threshold when the absorber was manually preset at f ai = 29.256 Hz: (a) response o f

mass ml without control, (b) response o f  mass mx with control, (c) the frequencies: solid 

line, excitation frequency; dashed line, estimated frequency, (d) the EMVA current.
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Figure 4.28 shows the results when the RMS-based method was applied. The threshold 

was 0.005 and the fine increase was 0.3. Figure 4.28 (a) shows the response o f  mass mx

without auto-tuning. Figure 4.28 (b) shows the response o f  mass mx when the EMVA

was activated. Figure 4.28 (c) shows the variation o f  the excitation frequency. Figure 

4.28 (d) shows the current to the EMVA. As shown in the figure, the response was small 

and the current was around zero during the first 6.7 seconds because the system was at 

the anti-resonance state and the value o f  RMS was small. After the system was set into 

the resonance at t = 6.7 second, the value o f RMS was increased significantly. It took 

0.512 second for the control system to react etnd the current changed. Then the response 

was reduced gradually. At t = 16.7 second it took 0.512 second for the control system to 

respond to the frequency change. It is interesting to note that unlike the previous two 

cases, the current was led to a positive value after t = 16.7 second. Although the EM VA 

was not tuned to achieve the anti-resonance according to the tuning condition, the 

stiffness o f  the EMVA was such that the system was tuned away from the resonance and 

vibration was suppressed.
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Figure 4.28 Experimental results using the RMS-based method when the absorber was 

manually preset at f ai -  29.256 Hz: (a) response o f  mass m] without control, (b) 

response o f mass m] with control, (c) the excitation frequency, (d) the EMVA current.
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Chapter 5

Conclusions and Future Work

5.1 Conclusions

The main object o f  this thesis was to apply the electromagnetic vibration absorber 

(EMVA) as a tunable vibration absorber in non-collocated vibration o f  a 3-DOF structure. 

The theoretic study on electromagnetism o f the EMVA was reviewed. A commercial 

package Comsol Multiphysics was used to simulate similar models. It was found that 

Comsol models correctly represented the magnetic flux densities o f electromagnetic coil 

by multiplying a factor o f 1.76, the magnetic flux density o f  the permanent magnet (PM), 

and the forces on the PM caused by the core as the PM in the gap o f  the electromagnetic 

core. By utilizing a simplified model, the magnetic forces on the PM under different 

currents was obtained. A coupling model, which coupled the structural mechanics o f  the 

beam with electromagnetic physics o f the coil and the PM, was built to simulate the force 

and displacement o f  the PM in different magnetizations. The results o f  the analytic and 

Comsol methods agreed in general. It was shown that Comsol Multiphysics was a useful 

software for solving problems related to electromagnetism, force and multiphysics. 

Multiphysics functionality o f Comsol offered a great potential in dealing with the 

characterization o f the mechatronics devices such as the EMVA.

A 3-DOF system was used to implement the non-collocated vibration control. By 

analyzing the frequency response, it was found that in most cases the vibration o f  a non- 

collocated mass could be thoroughly attenuated through adjusting the stiffness o f the 

absorber such that one o f the natural frequencies o f  the subsystem was equal to the 

excitation frequency if  there was no damping between the absorber and the primary 

system.

Three auto-tuning methods had been developed. The first method, FFT-based method, 

was based on the frequency measured through the response. The second method, FFT- 

based plus fine tuning, added a fine controller which modifies the current determined 

from the coarse controller. The third method, RMS-based method, used the root-mean-
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square value o f  the response. The first and second methods controlled the vibration o f  the 

system by adjusting the current o f the EMVA based on the analytic study o f  the system. 

In case the physical conditions o f the model or the EMVA changed, the first method 

could not correct the differences. The second method showed a better result than the first 

method if  physical conditions o f the system changed. The third method controlled the 

system in a slower speed and based on the precondition that the amplitude o f the 

objective mass in the changing range o f the frequency spectrum was unimodal. I f  the 

precondition did not exist, the method did not work effectively.

5.2 Future Work

The work undertaken is the study o f the EMVA and the non-collocated control. To 

apply the EMVA in a wider range o f  bandwidth, its structure may need to be modified 

such that a manual adjusting is easier and the adjusting range is larger enough to be used 

in suppressing the first natural frequency o f  the primary system. Study on the new 

EMVA is required such that it is more efficient. This can be facilitated with the help o f  

Comsol Multiphysics, especially for complicated structures and multi-physical conditions. 

Applying Comsol Multiphysics in the study o f  a whole system is also one o f the potential 

tasks.
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Appendix A

Determination of coA, coB, cor and con in Equation (3.12)

Consider Equation (3.8) in Chapter 3

1 + Jc + m2m3)s* + (k3m3 + k3ma + k2ma + m2k3 + k2m3)s 2 + k2k3 _
ma s 2 [tn2m3 s4 + (k3m3 + m2k3 + k2m3)s2 + k2k3]

Let

a = m2ma + m2m3

b = k3m3 + k3ma + k2ma + m2k3 + k2rn3 

B = k3m3 + m2k3 + k2m3

Equation (A -l) becomes

, . as4+bsz +k.>L
1 + ka   ----------  ^  = 0

mas [m2m3s  4-Bs + k2k3]

Equation (A -l) can also be written in the factored form

 = 0
ma(m2m3)s (s +coB)(s +coD)

When ka -  0 , for equation (A-2) the following equation exists

mam2m3s 6 + maB s2 + mak2k3 = 0

And for equation (A-3) the following exists
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mam2m2(s2 + col)(s2 +coj)) — 0 

or

mam2m3s 6 + mam2m3(oj2 + cofys* + mam2m3o)2B(D2D = 0 

As equation (A-4) equals equation (A-5)

™aB = mam2m3{co2B +co2D)

mak2k3 = mam2m3(o2Bco2D

From (A-6) and (A-7), the following results are obtained

B  ± -\Jb2 — 4m2m3k2k3 
C t)p  4 I ~

2 m2m3

I 2 k2k3
® o =

B ± -Jb 2 -  4m2m3k2k3 

When ka =oo, for equation (A-2) the following equation exists

as4 4- bs2 + k2k3 = 0

And for equation (A-3) the following equation exists

a(s2 +a)2)(s2 +co2) = 0
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or

as* + a(a>l + col )s2 + ao)A0)2 = ® (A- * ' )

As equation (A -10) equals equation (A-l 1)

a = a(a>2A + a>l) (A-12)

k2k3 = aco\(o2c (A -13)

From (A-12) and (A -13), the following results are obtained

b ± j b 2- 4 a k 2k3 
2 a

o>a =
2k2k3

I b ± y jb 2 - 4 a k 2k3

(A -14) 

(A -15)

As the following parameters are considered

mx = 2.73 kg ; m2 = 2.048 k g ; m3 = 2.635 kg ; ma = 0.2515 kg ; A:, =17181 N /m ; 

k2 = 35401 N/m ; kx = 20616 N/m .

The following results are obtained

coAX =10.1361 H z ; mA% =27.7671 H z; coBX =175.4495 H z ; coR2 =66.2831 H z; 

cocx =59.9199 H z; a C2 =164.1465 H z; a>DX =10.5493 H z; a>m  =27.9236 H z.

It must be noted that coA, coB,coc and coD mentioned in Section 3.4 o f  Chapter 3 (Page 

50-52) are now represented as coAl, coDX, coA2 and coD2, respectively. Because only the
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frequency under 40 Hz is considered, all other frequencies obtained by equation (A-8), 

(A-9), (A -14), (A-15) above 40 Hz were considered infinite.

105

Reproduced with permission of the copyright owner. Further reproduction prohibited without permission.



Appendix B 

Procedure to Build the Electromagnet Model 

(Comsol 3.3a)

MODEL NAVIGATOR 

Select COMSOL Multiphysics, select 3D> AC/DC Module>Statics> 

Magnetostatics mode in the Model Navigator.

OPTIONS AND SETTINGS 

In Options> Constants, enter the following names and expressions.

Name Expression Description

murFe 25 Relative permeability o f steel

R 0.05 Radius o f  the torus center line

r 0.015 Medium radius o f the electromagnetic coil

GEOMETRY MODELING

Building a hollow torus

1. In Draw>Work Plane Setting>Plane, click ‘x-y, z :0’. Click OK.

2. Draw a circle with a diameter o f 0.03 (A-semiaxes: 0.015; B-semiaxes: 0.015) with 

the center at (0.05, 0), the name is E l .

3. Draw a circle with a diameter o f 0.025 (A-semiaxes: 0.0125; B-semiaxes: 0.0125) 

with the center at (0.05, 0), the name is E2„

4. Click the inner circle. Hold Ctrl key and click the outer circle.

5. Open Draw> Create Composite Object.

6. In Set formula, input ‘E1-E2’. Click OK.

7. In Draw> Revolve, select Revolution. In Revolution axis> Point on axis: x=0, y=0; 

Axis direction through> Second point: x=0, y= l. Click OK.

Now a hollow torus is formed.

Building a solid block
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Draw a circle with a diameter o f 0.025 with the center at (0.05, 0), the name is E2.

In Draw> Revolve, select Revolution. In Revolution axis> Point on axis: x=0, 

Axis direction through> Second point: x=0, y= l. Click OK.

Now a solid torus is formed.

Building a block

1. In Draw, select Block.

2. In ‘Base’, select center.

3. In Length, select: X=0.043, Y=0.045, Z=0.05.

4. In Axis base point, select: x=0, y=0, z=0.05.

Now a block (BLK1) is formed.

Copying a block

1. Copy the block made above.

2. Paste the block. Choose the displacement: x=0, y=0, z=0.

Now another block (BLK2) is formed.

Forming the gap

1. Open Draw > Create Composite object.

2. In ‘Set formula’, input ‘REV1-BLK1’. Click OK.

3. In ‘Set formula’, input ‘REV2-BLK2’. Click OK.

Now the hollow torus (C 02) and the solid torus (C O l) are cut with a gap.

Creating a block for free space

1. In Draw, select Block.

2. In Base, select center.

3. In Length, select: X=0.2, Y -0.2, Z -0.2.

4. In Axis base point, select center and enter: x=0, y=0, z=0.

Now a block is formed (BLK1).
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PHYSICS SETTINGS FOR ELECTROMAGNETICS 

Apply the Current

1. In Physics> Subdomain Settings.

2. Select B = for all subdomains.

Subdomain Settings

In the Subdomain Settings dialog box, enter the coefficients according to the table below.

SUBDOMAIN i 2 3

Mr l 1 murFe

r 0 - JO * x* y/(r * sqrt(xA2+z A2)) 0

0 JO * (sqrt(xA2+zA2) -R)/r 0

0 - JO *z * y / (r * sqrt(xA2+z A2)) 0

Boundary Conditions

Keep default boundary conditions according to the table below.

BOUNDARY 1-5, 42 ALL OTHER

Boundary condition Magnetic insulation Dim (keep default)

MESH GENERATION

1. In Mesh> Free Mesh Parameters, select ‘Extra coarse’ in Predefined mesh sizes.

2. Click OK.

COMPUTING THE SOLUTION

1. From the Solver menu open the Solver Parameters dialog box.

2. Go to the Solver list and select Parametric.

3. In the Name of parameter edit field, type JO.

4. In the List of parameter values edit field enter 581343*1.76:581343*1.76: 

2325372*1.76.

5. In Linear system solver edit field, select Direct (UMFPACK).
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6. Go to the Parametric in the same dialog window, select Linear in Predictor edit 

field.

7. Go to the Stationary in the same dialog window, select Automatic in Linearity edit 

field.

8. Click OK.

9. Click the Solve button on the Main toolbar (Solve> Solve Problem).

Postprocessing

1. Go to Options> Suppress> Suppress Boundaries.

2. Select 1 ,2 , 3 ,4 , 5, and 42. Click.

3. Open Postprocessing> Plot Parameters> General, select Boundary, Arrow.

4. Open Postprocessing> Plot Parameters> Arrow, select Total current density in 

Subdomain Data. Still in Arrow, select x points, y points and z points, and enter 

Number of points=30 the three directions. Click Apply. The arrow plot o f  current 

density is shown.

5. Open Postprocessing> Cross-Section Plot Parameters>Line/Extrusion. In y-axis 

data, in Prdefined quantities, select Magnetic flux density, x component. In x-axis 

data, select x. In Cross-section line data, input: x0=-0.0185, xl=0.0185. y0=0, y l= 0 , 

z0=0.05, zl=0.05.

6. Click Apply. The magnetic flux density along the centerline between C-gap is shown.
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Appendix C 

Part I. Procedure to build a coupling model 
(Comsol 3.3a)

This instruction shows the procedure o f building the coupling model shown in Figure 

2.30. The primary problem the model addresses is the 2-way coupling between the 

deformations and the magnetic field. It solves the magnetic equation in the air domain 

surrounding the model using the arbitrary Lagrangian-Eulerian (ALE) method to account 

for geometry changes associated with the deformation.

MODEL NAVIGATOR

1. In the Model Navigator select 2D in the Space dimension list and then click 

Multiphysics.

2. From the list o f  application modes on the left side o f the dialog box select Structural 

Mechanics Module>Plane Stress and then click Add.

3. From the list o f  application modes select COMSOL Multiphysics>Deformed 

Mesh>Moving Mesh (ALE) and then click Add.

4. In the Multiphysics list on the right side o f the dialog box select Frame (Ale) then 

add AC/DC Module> Quasi-Statics, Magnetic> Perpendicular Induction 

Currents, Vector Potential (emqa) to that list.

OPTIONS AND SETTINGS

In Options> Constants, enter the following names and expressions.

Name Expression Value D escription

mpre 45000 45000 Magnetization o f  the upper and lower PMs

Mpre 395800 395800 Magnetization o f the middle PM

GEOMETRY MODELING

1. Draw the following rectangles:
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Rectangle name Width Height X Y

R l( le f t  beam) 0.1 0.0015 -0.124 -0 .00075

R2(right beam) 0.1 0.0015 0.024 -0.00075

R3(middle PM) 0.048 0.038 -0.024 -0.019

R4(upper gap) 0.048 0.0025 -0.024 0.019

R5(lower gap) 0.048 0.0025 -0.024 -0.0215

R6 0.1 0.02075 -0.124 -0.0215

R7 0.1 0.02075 -0.124 0.00075

R8 0.1 0.02075 0.024 -0.0215

R9 0.1 0.02075 0.024 0.00075

RIO (lower PM) 0.048 0.04 -0.024 -0.0615

R 11 (upper PM) 0.048 0.04 -0.024 0.0215

R12 0.1 0.04 -0.124 0.0215

R13 0.1 0.04 -0.124 -0.0615

R14 0.1 0.04 0.024 -0.0615

R15 0.1 0.04 0.024 0.0215

R16 0.248 0.12 -0.124 -0.1815

R17 0.248 0.12 -0.124 0.0615

2. Click the Zoom Extents button on the Main toolbar at the top o f the graphical user 

interface.

3. Go to Draw>Draw Objects>Point. Draw a point PT17 at X=0 and Y=0. Point 

position can be adjusted by going to Draw>Object Properties, selecting 1 in Point 

edit field. Enter 0 for x and y.

PHYSICS SETTINGS FOR ELECTROMAGNETICS

Subdomain Settings

1. Go to the Multiphysics menu and make sure that Perpendicular Induction Currents, 

Vector Potential (emqa) is selected.

I l l

Reproduced with permission of the copyright owner. Further reproduction prohibited without permission.



2. Open the Physics>Subdomain Settings dialog box and select all Subdomains except 

the three PMs (Subdomains 8, 10, 12). The default settings = 1) corresponds to

air, so keep them. While still in that dialog box, select Subdomain 8. In constitutive 

relation, select B  = fj,aH  + fi0M  . In the magnetization edit field M, input 0 and Mpre

for X and Y magnetization, respectively. In Forces, input Fes in Name. Return to 

the dialog box in Physics, select Subdomain 10, 12. In constitutive relation, select 

B = /u0H  + ju0M . In the magnetization edit field M, input 0 and mpre for X and Y

magnetization, respectively.

3. Click OK.

Boundary Conditions

1. From the Physics menu open the Boundary Settings dialog box.

2. Keep Interior Boundaries clear. Keep default conditions (Boundaries 1, 2, 3, 5,

7, 9, 11, 13, 15, 42-48: Magnetic insulation. Other Boundaries: Continuity).

3. Click OK.

PHYSICS SETTINGS FOR MOVING MESH

Subdomain Settings

1. From the Multiphysics menu select Moving Mesh (ale).

2. In the Subdomain Settings dialog box select the Subdomains for air (except 

Subdomains 4, 8, 10, 12, 15). Keep the default Free displacement setting.

3. While still in that dialog box select Subdomains 8, 12 (the upper and lower PMs). 

Select Mesh> No displacement. Select Subdomains 4, 10, 15 (the middle PM, right 

and left beams). Select Mesh> Physics induced displacement. For the displacement 

variables, dx and dy, enter u and v respectively. There are the displacements from the 

Plane Stress application mode.

4. Click OK.

Boundary Conditions
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1. From the Physics menu open the Boundary Settings dialog box.

2. In the Boundary Settings dialog box for the mesh displacements, dx and dy, enter 

the following values for outer settings:

SETTINGS Subdomains 1, 2, 3, 5, 9, 

11, 13, 15-17, 19, 26-29, 

39, 42-44, 46-48

Subdomains 8, 10,

20,21,23, 25,33, 

35, 37

ALL OTHER

Dx 0 u Do not assign

Dy 0 V Do not assign

3. Click OK.

Properties

1. From Physics> Properties> Application Mode Properties dialog box, select 

Winslow in Smooth method.

2. Click OK to close the dialog box.

PHYSICS SETTINGS FOR PLANE STRESS

Application Mode Properties

1. From Multiphysics menu choose Plane Stress (smps).

2. From the physics menu open the Properties dialog box.

3. Click the Application Mode Properties button, go to the Large deformation list, 

select On; then click OK.

4. Click OK to close the dialog box.

The large-deformation option ensures that the solver uses a nonlinear stress-strain 

relationship to calculate the results in the Plane Strain application mode.

Subdomain Settings

1. In the Subdomain Settings dialog box select Subdomain> Material enter the 

following settings:
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N am e Subdom ains 4 ,15 Subdom ains 10

E 70e9 70 e l l

V 0.33 0.33

a 23e-6 23e-6

P 2700 2700

Thickness 1 1

2. While still in the dialog box select Subdomains 4, 10, 15 and click Active in these 

Subdomains. Select all other Subdomains and clear Active in this domain to 

inactive these domains.

3. Click OK.

Boundary Conditions

1. From the Physics menu select Boundary Settings. In the resulting dialog box verify 

that the Interior boundaries check box is cleared.

2. Click the Constraint tab, then select Boundaries 7, 45. From the Constraint 

condition list select Fixed. For all other Boundaries, select Free.

3. In the same window, click the Load tab, then select Boundaries 21 and 25. In the 

Value/expression edit field for Fx enter 0 and for Fy enter Fes_nTy_emqa. For all 

other Boundaries, select default Fx=0 and Fy=0.

4. Click O K  to accept the boundary conditions.

Point Conditions

Apply a variable force Fy on the center point o f the middle PM in y-direction.

1. Click the Physics>Point Settings tab. Select Point 17. Click Load, and enter 0 for 

Fx and Fy for Fy.

2. Click OK.

MESH GENERATION

1. Select Mesh> Free Mesh Parameters, select Fine in Predefined mesh sizes.
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2. Click OK.

3. Click Initialize Mesh to complete mesh.

COMPUTING THE SOLUTION

1. From the Solver menu open the Solver Parameters dialog box.

2. Go to the Solver list and select Parametric.

3. In the Name of parameter edit field, enter Fy.

4. In the List of parameter values edit field enter -2100:100:2100.

5. In Linear system solver edit field, select Direct (UMFPACK) in Linear system 

solver.

6. Go to the Parametric edit field in the same dialog window, select Linear in 

Predictor edit field.

7. Go to the Stationary in the same dialog window, select Automatic in Linearity edit 

field. And click Highly nonlinear problem.

8. Click OK.

9. Click the Solve button on the Main toolbar (Solve> Solve Problem).

POSTPROCESSING AND VISUALIZATION

To view magnetic field and displacement o f the middle PM and beam, follow these

instructions:

1. From the Postprocessing menu open the Plot Parameters dialog box.

2. On the General page select Boundary and Arrow. Make sure the check boxes for all 

other types are cleared.

3. Go to the Boundary. Enter 1 in Expression. Go to the Arrow, select Magnetic flux 

density in Subdomain Data> Predefined quantities. Click OK.

4. Go to Postporcessing> Domain Plot Parameters> Line/Extrusion. Select y- 

displacement in y-axis data>Predefined quantities. Select 8 in Boundary selection.

5. Click Apply. The deformation o f the left beam is shown.
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Part II. Procedure to build a simple coupling model

This instruction shows the procedure o f  building a simple coupling model shown in 

Fig A .I. The model is the same as Figure 2.30 except it has only the same boundary 

rectangle, three PMs and two beams while moving away other rectangles. It solves the 

magnetic equation in the air domain surrounding the model using the arbitrary 

Lagrangian-Eulerian (ALE) method to account for geometry changes associated with the 

deformation.

0,15

0.1

0.C6

0

-0.05

-0.1

-0.15

MODEL NAVIGATOR

1. In the Model Navigator select 2D in the Space dimension list and then click 

Multiphysics.

2. From the list o f  application modes on the left side o f the dialog box select Structural 

Mechanics Module>Plane Stress and then click Add.

3. From the list o f  application modes select COMSOL MuItiphysics>Deformed 

Mesh>Moving Mesh (ALE) and then click Add.
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4. In the Multiphysics list on the right side o f the dialog box select Frame (Ale) then 

add AC/DC ModuIe> Quasi-Statics, Magnetic> Perpendicular Induction 

Currents, Vector Potential (emqa) to that list.

OPTIONS AND SETTINGS

In Options> Constants, enter the following names and expressions.

Name Expression Value Description

mpre 45000 45000 Magnetization o f the upper and lower PMs

Mpre 395800 395800 Magnetization o f the middle PM

GEOMETRY MODELING

1. Draw the following rectangles:

Rectangle name Width Height X Y

R1 (boundary rectangle) 0.248 0.363 -0.124 -0.1815

R2(upper PM) 0.048 0.04 -0.024 0.0225

R3 (lower PM) 0.048 0.04 -0.024 -0.0625

R4(middle PM) 0.048 0.04 -0.024 -0.02

R5(left beam) 0.1 0.0015 -0.124 -0.00075

R6(right beam) 0.1 0.0015 0.024 -0.00075

2. Click the Zoom Extents button on the Main toolbar at the top o f  the graphical user 

interface.

3. Go to Draw>Draw Objects>Point. Draw a point PT17 at X=0 and Y=0. Point 

position can be adjusted by going to Draw>Object Properties, selecting 1 in Point 

edit field. Enter 0 for x and y.

PHYSICS SETTINGS FOR ELECTROMAGNETICS
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Subdomain Settings

1. Go to the Multiphysics menu and make sure that Perpendicular Induction 

Currents, Vector Potential (emqa) is selected.

2. Open the Physics>Subdomain Settings dialog box and select all Subdomains except 

the three PMs (Subdomains 4, 5, 6). The default settings ( p r = 1) corresponds to air,

so keep them. While still in that dialog box, select Subdomain 5. In constitutive 

relation, select B = ju0H  + ju0M  . In the magnetization edit field M, enter 0 and Mpre

for X and Y magnetization, respectively. In Forces, input Fes in Name. Return to 

the dialog box in Physics, select Subdomain 4, 6. In constitutive relation, select 

B -  /u0H  + f o M . In the magnetization edit field M, input 0 and mpre for X and Y

magnetization, respectively.

3. Click OK.

Boundary Conditions

1. From the Physics menu open the Boundary Settings dialog box.

2. Keep Interior Boundaries clear. Keep default conditions (Boundaries 1, 2, 3, 5,

7, 26-28: Magnetic insulation. Other Boundaries: Continuity).

3. Click OK.

PHYSICS SETTINGS FOR MOVING MESH

Subdomain Settings

1. From the Multiphysics menu select Moving Mesh (ale).

2. In the Subdomain Settings dialog box select the Subdomain 1 for air. Keep the 

default Free displacement setting.

3. While still in that dialog box select Subdomains 4, 6 (the upper and lower PMs). 

Select Mesh> No displacement. Select Subdomains 2, 5, 7 (the middle PM, right and 

left beams). Select Mesh> Physics induced displacement. For the displacement 

variables, dx and dy, enter u and v respectively. There are the displacements from the 

Plane Stress application mode.
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4. Click OK.

Boundary Conditions

1. From the Physics menu open the Boundary Settings dialog box.

2. In the Boundary Settings dialog box for the mesh displacements, dx and dy, enter 

the following values for outer settings:

SETTINGS Subdomains 1, 2, 5, 

7-10, 16-19, 25-26, 

28

Subdomains 4, 6, 

11,12, 14, 15,20, 22, 

23 ,24

ALL OTHER

dx 0 u Do not assign

dy 0 V Do not assign

3. Click OK.

Properties

1. From Physics> Properties> Application Mode Properties dialog box, select 

Winslow in Smooth method.

2. Click OK to close the dialog box.

PHYSICS SETTINGS FOR PLANE STRESS

Application Mode Properties

1. From Multiphysics menu choose Plane Stress (smps).

2. From the physics menu open the Properties dialog box.

3. Click the Application Mode Properties button, go to the Large deformation list, 

select On; then click OK.

4. Click OK to close the dialog box.

The large-deformation option ensures that the solver uses a nonlinear stress-strain 

relationship to calculate the results in the Plane Strain application mode.
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Subdomain Settings

1. In the Subdomain Settings dialog box select Subdomain> Material enter the

following settings:

Name Subdomains 2, 7 Subdomains 5

E 70e9 70 e l l

V 0.33 0.33

a 23e-6 23e-6

P 2700 2700

Thickness 1 1

2. While still in the dialog box select Subdomains 2, 5, 7 and click Active in these 

Subdomains. Select all other Subdomains and clear Active in this domain to 

inactive these domains.

3. Click OK.

Boundary Conditions

1. From the Physics menu select Boundary Settings. In the resulting dialog box verify 

that the Interior boundaries check box is cleared.

2. Click the Constraint tab, then select Boundaries 3, 27. From the Constraint 

condition list select Fixed. For all other Boundaries, select Free.

3. In the same window, click the Load tab, then select Boundaries 12 and 15. In the 

Value/expression edit field for Fx enter 0 and for Fy enter Fes_nTy_emqa. For all 

other Boundaries, select default Fx=0 and Fy=0.

4. Click OK to accept the boundary conditions.

Point Conditions

Apply a variable force Fy on the center point o f the middle PM  in y-direction.

1. Click the Physics>Point Settings tab. Select Point 13 (PT1). Click Load, and enter 0 

for Fx and Fy for Fy.

2. Click OK.
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MESH GENERATION

1. Select Mesh> Free Mesh Parameters, select Fine in Predefined mesh sizes.

2. Click OK.

3. Click Initialize Mesh to complete mesh.

COMPUTING THE SOLUTION

1. From the Solver menu open the Solver Parameters dialog box.

2. Go to the Solver list and select Parametric.

3. In the Name of parameter edit field, type Fy.

4. In the List of parameter values edit field enter -2100:100:2100.

5. In Linear system solver edit field, select Direct (UM FPA CK ) in Linear system 

solver.

6. Go to the Parametric edit field in the same dialog window, select Linear in 

Predictor edit field.

7. Go to the Stationary in the same dialog window, select Automatic in Linearity edit 

field. And click Highly nonlinear problem.

8. Click OK.

9. Click the Solve button on the Main toolbar (Solve> Solve Problem). 

POSTPROCESSING AND VISUALIZATION

To view magnetic field and displacement o f the middle PM and beam, follow these 

instructions:

1. From the Postprocessing menu open the Plot Parameters dialog box.

2. On the General page select Boundary and Arrow. Make sure the check boxes for all 

other types are cleared.

3. Go to the Boundary. Enter 1 in Expression. Go to the Arrow, select Magnetic flux 

density in Subdomain Data> Predefined quantities. Click OK.

4. Go to Postporcessing> Domain Plot Parameters> Line/Extrusion. Select y- 

displacement in y-axis data>Predefined quantities. Select 6 in Boundary selection.

5. Click Apply. The deformation o f  the left beam is shown.
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Appendix D 

Development o f a Control Model using dSPACE ConrolDesk 

(ControlDesk Developer Version 2.1.1)

Part I. Procedures

1. Turn on Computer.

2. Open Matlab first, and then open Simulink.

3. Open the simulink model built.

4. Open DSpace Controldesk to get into the ControlDesk environment.

5. Set up the new ControlDesk Layout file: File > New > Layout, then save it.

6. Go back to Simulink. Build Simulink model: Tools > Real-Time Workshop > Build 

Model.

7. Back to ControlDesk. Set up the connection between ControlDesk and Simulink: 

Data Acquisition (on the right o f  the screen) > click CaptureSettings > click any 

point on the Layout window, hold the pointer to draw a small window for the 

instruments to be embedded in > double click this small window, a window dSPACE 

Capture Settings Control Properties comes out. In this window, select Capture 

and click down arrow “ T ” to select the name o f the corresponding Simulink Model 

(now the connection between the Simulink model and ControlDesk Layout file has 

been established).

8. Switch to Edit Mode > Stop (small red box on the toolbar). Double click the window 

dSPACE Capture Settings Control Properties mentioned in “7” . The window 

comes out again. In Capture, change the time Length o f the data acquisition. Auto 

Repeat means the old data obtained in the previous time Length will be overwritten 

with another new acquisition. Downsampling means the sampling time, for example, 

Downsampling 1 means sampling time = 0.001 s, 3 means sampling time = 0.003 s. 

Increasing Downsampling means recording the data using a slower sampling time.
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If  more data (such as selecting more P lo tter in Data-Acquisition or increase the 

Length o f  time) are selected, Downsampling will be increased due to the limited 

memory o f  the computer. All data shown on Plotters are collected.

To save data, in the window dSPACE Capture Settings Control Properties, select 

Acquisition. Select Autosave and assign a file name with a root in Acquisition. If 

OK or Apply at the bottom o f  the window is clicked, a file name is formed in the 

assigned place. But now there are no data in the file. dSPACE has to be run to form 

them.

9. Now it is the time to add other instruments in the Layout to control the corresponding 

elements in Simulink Model. It is known that ControlDesk provides an environment 

to visually and online control the process in which the Simulink Model is executed. 

So each element in the Simulink Model can be controlled or manipulated through the 

corresponding visualized instruments in the ControlDesk file. These instruments can 

be found on Visual Instruments (on the right o f  the screen). Some o f  the frequently 

used ones are Display, Numericlnput, OnOffButton, and Slider. Some other 

instruments can also be found from Data Acquisition (on the right o f  the screen) 

such as CaptureSettings and Plotter.

10. Connect a virtual instrument to a variable o f the Simulink model. For example, if  the 

output o f ADC 1 gain (ADC 1 gain is an operator used in the Simulink model) is to be 

plotted. Check the small tab at the bottom o f the Layout Screen, the Simulink Model 

file can be seen. It may need to bring the window up to reduce the size o f Layout 

window. Model file is Model Root which contains all Simulink variables. From this 

list, find ADC 1 gain and select it. Now on the right screen, Gain and Outl can be 

seen. Drag Outl to Plotter (already placed on Layout window). Notice that, after 

Outl at Plotter is released, the red frame around Plotter disappears, which means 

that Plotter is associated with variable O u tl.

It must be careful that the operation can only be completed when Tool Window is 

activated. If there is no Tool Window on ControlDesk, click “Activate Tool 

Window from main menu > View > Activate Tool Window to activate the Tool 

Window. At the bottom o f the Tool Window, there are four choices: Log Viewer, 

File Selector, Interpreter and Model Root. Model Root is in the form such as
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‘C:\matIab\work\testsampIe”. To plot an output, click C:\matlab\work\testsample 

before select the output.

11. Another example, to use Slider to control the gain o f ADClgain. Click Slider under 

Virtual Instrument and draw a box on Layout window. Then, drag Gain under 

Variable and release it on Slider.

12. Do the same to any variable to control or to output in the Simulink model.

13. Once the connections for all the elements have been established, run the program: run 

(green triangle) > Animation Mode.

14. After the program runs a period, stop it. The data are saved in the root directory 

assigned in “8” with the same name. Then load the data fde under Matlab 

environment using command: load the filename. Note the data file is in Matlab mat 

format. When the data file is loaded, it is a Matlab structure. The size o f  the structure 

is decided by the number o f Plotter, the Length o f  time and Downsampling number. 

Consult Matlab manual for the instruction o f how to access Matlab structures.

Part II. Sample of dSPACE operation

1. Turn on Computer.

2. First open Matlab, then open Simulink.

3. Open the simulink model: C:\Matlab\ work\Novemberl\nov.mdl.

4. Open DSpace Controldesk to get into the ControlDesk environment.

5. Go back to Simulink model opened in step 3. Build Simulink model: Tools > Real- 

Time Workshop > Build Model.

6 . Go to ControlDesk. Open the dSPACE model from C:\Matlab\ work\ 

November 1 YNov 1 test.lay.

7. In this window dSPACE Capture Settings Control Properties, select Capture and 

click down arrow to select the name o f  the corresponding Simulink Model (now 

the connection between the Simulink model and ControlDesk Layout file has been 

established. If  there is no connection, choose ‘DPS_nov_position capture’).

In Interval, Length, change to 5 (second).
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To save data, in the window dSPACE Capture Settings Control Properties, select 

Acquisition. Select Autosave and assign a file name ‘datasample’ in a directory. 

Click O K  or Apply at the bottom o f  the window, a file name is formed in the 

directory ‘ C:\Matlab\ work\ N ovem berl’. But now there are no data in the file. The 

user has to run dSPACE to form them.

8. Click the start button in dSPACE. Run it for more than 5 seconds. Then stop. Now 

the data are saved.

Postprocessing the data:

Typical operation example for data saving and data processing:

a. Following “8” : To save data, from Acquisition select Autosave and assign 

C:\matlab\work\datasample. The file name is datasample and the root directory is 

C:\matlab\work. Click O K  or Apply at the bottom o f the window, a file name 

“datasample” is formed in C:\matlab\work.

b. Run the program for a full period o f  time, the data are saved. Load the file under 

Matlab environment using command:

Load datasample.

datafile^datasample

datal=double(datafile.Y(:, 1 ).Data);

data2=double(datafile.Y(:,2).Data);

figure(l) 
plot(datal) 
figure (2) 
plot(data2)

Note the data file structure is decided by the number o f the plotters. The sample uses only 

two plotters.
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